Jump to content
Ericfoos

Certain clients do not groom old snapshots.

Recommended Posts

I have a backup set called Desktops.  It runs overnight to disk.  In the morning a groom script runs.   The backup set preference for grooming is the last 4 backups.

Onlycertain clients groom correctly.  I have to go in and manually forget the old snapshots for the clients that do not groom automatically.

Has anyone else seen this?  Is there an easy solution?  Manually removing snapshots is very time consuming.

 

Share this post


Link to post
Share on other sites

It happens here when a client has been forgotten and re-added (such as when Windows is re-installed). Retrospect sees them as separate clients and the oldest client's four backups linger on forever.

 

Does this fit with your situation?

Share this post


Link to post
Share on other sites

Unfortunately not.  I have seen taht behavior before when moving users to new computers.  I have purged the offending snapshots to the grooming specifications and subsequent backups continue to not be groomed requiring me to manually groom again.  I did notice in the "Restore" area that some backup clients have human heads instead of computers.  Not sure if that is part of the problem or not.

Share this post


Link to post
Share on other sites

For the client with eight snapshots in the screen shot's left half, what are the dates for the snapshots?

 

Have you recreated the catalog file from disk? Repaired it?

Share this post


Link to post
Share on other sites

It's a new set.  Had a disk failure a few weeks ago so I started from scratch on the new disk.

Dates are

8/13,14,20,21,22,25,26,27

 

The dates for the 8 snapshot client in the restore area that have a human head are

8/20,21,25,26

The other 4 snapshots have a computer icon.

Share this post


Link to post
Share on other sites

Wed, Thu, but not Fri the first week.

Wed, Thu, Fri the second week but not Mon, Tue.

Mon, Tue, Wed the current week.

 

What can we make out of this? Not much, I guess.

I was expecting four weekdays in a row, a gap and then the last four weekdays.

 

Any problems/errors with the backups of this client? With any other client?

Share this post


Link to post
Share on other sites

Yeah, the pattern of leaving a group of snapshots behind is what I'm used to seeing when some bit changes to make the server think it is a new client.

The backups don't complain at all for any client that does not groom.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×