Jump to content
zer0aster

Rebuilding disk Media Set - Needs Media

Recommended Posts

I have a single media set with 2 members, each member being on a different NAS share. The total size of the backed up data being 4.5 TB.

 

Recently when restoring files we have had the "needs media" error come up. I am using a Mac for the server and client, and I am not mounting the NAS shares in the Finder. But I can independently access the shares on another computer to check that files are present.

 

Verifying the Media Set eventually gives the needs media error. I don't attempt to Choose media, as I know that way lies madness. The usual operator selected Choose Media while restoring and inadvertently littered the share with new folders/members that contain nothing.

 

Repairing the Media Set allows me to select the members. It tells me how many files are in each, and the verification lasts for just 1 second and proclaims success, but really nothing has changed thereafter. Restores still fail.

 

Rebuilding allows me to select the members, review information about them, and the rebuilding process begins, but stops with "needs media".

 

I have removed and added both shares to the Sources list also, and tried the above again. The shares are accessed via SMB. I have closed down other networking services on these shares.

 

I am running Retrospect 10.1 on a Mac OSX 10.6.8, backing up to 2 Samba shares running on two identical QNAP NAS devices.

 

My next step seems to be to put transfer the media to local USB disks and try to rebuild from there. A lot of data to throw about, so this is getting time consuming as well as futile. I would be grateful for any bright ideas to resolve this issue.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×