Jump to content
Lennart_T

Windows clients locked up during "Building snapshot"

Recommended Posts

+ Retrospect version 7.6.123

+ Driver Update and Hot Fix, version 7.6.2.101

Windows Client version 7.6.107.

 

Many of our client complaints that their computer locks up completely for about 15 minutes during (part of) the "Building snapshot" phase of the backup.

 

The client hardware is laptops with everything from core 2 dual to quad core i5 processors. Usually Windows 7, some have Vista. None have Windows 8.

 

Why is this happening?

Is this fixed in later versions?

Can we update the client software? To which version?

 

(Yes, I have asked for money to upgrade to version 8, but money isn't available...)

Share this post


Link to post
Share on other sites

Hi Lennart

 

Do you know what the spindle speed is of the hard drives in the laptops? During the building of the snapshot Retrospect appears to crawl the entire file system of the volume and a slow disk and/or interface can cause a performance bottleneck.

 

In the past I had a Dell laptop (Windows XP) with a 4200 rpm disk and it would become unresponsive during the disk intensive part of the snapshot building. The current Dell laptops (Windows 7 and Windows 8.1, both 64-bit) I have with 7200 rpm disks are much better although some performance degradation can sometimes be noticed. The version of Retrospect and Retrospect Client seems to make little difference.

Share this post


Link to post
Share on other sites

Another possible avenue to investigate is the antivirus software if you have it installed on the laptops.

 

I have found that, if supported by the antivirus software, excluding the Retrospect Client processes from its real time monitoring of file access can lighten the disk load and improve backup performance.

Share this post


Link to post
Share on other sites

Thank you for your thoughts.

 

I think most drives are 5400 rpm drives.

 

It's true that our anti-virus (McAfee) can be a CPU hog, but not during backup. Task manager doesn't show any anti-virus activity.

Share this post


Link to post
Share on other sites

This has been happening for years on my site and it's down to disk speed. Maybe disk fragmenting might help with overall disk performance when being scanned during the snapshot, all our new laptops comes with SSD's and you can't even tell when a backup is taking place with them.

Share this post


Link to post
Share on other sites

Short of  buying a dozen new hard drives (SSD or not), is there anything that can be done? Optimize the disk directory, for instance?

Share this post


Link to post
Share on other sites

If McAfee allows you to exclude specific processes from being monitored for file accesses then try adding C:\Program Files (x86)\Retrospect\Retrospect Client\retroclient.exe and C:\Program Files (x86)\Retrospect\Retrospect Client\pcpds.exe (64-bit system) to the exclusion list. This, without installing an SSD, is the only way I have found to improve performance on resource constrained hardware where an antivirus application is running.

 

On my Dell laptops I use Microsoft Security Essentials on Windows 7 and XP and Windows Defender on Windows 8.1 and these allow for the exclusion of processes from real-time monitoring of file activity.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×