Jump to content
haggis999

Retrospect not starting automatically for scheduled backups

Recommended Posts

I am a long term user of Retrospect Pro for Windows and am currently running version 7.7 under 64-bit Windows 7.

 

In the past, I used external hard disks that were stored away from my primary PC. However, I now have the ability to exploit scheduled backups due to the purchase of a couple of Synology NAS units. I plan to run a scheduled Retrospect backup of my PC to NAS #1 (located onsite in a separate room from my PC) and then run a later backup session (using a Synology app) to copy files from NAS #1 to NAS #2 (located in a separate fire zone).

 

My problem is that Retrospect does not automatically start up at my scheduled time to run my daily backup job. I have selected 'Always run Retrospect as the specified user' under Preferences/Security and have specified my admin login details. I have also selected both 'Enable Retrospect Launcher service' and 'Automatically Launch Retrospect' under Preferences/Startup. Is something else required to make the automatic launch facility work?

 

David

 

  • Like 1

Share this post


Link to post
Share on other sites

In Computer Services check to see if

 

RetroLauncher

 

has 'Allow service to interact with desktop' checked in the 'Log On' tab.

 

I think 'Secondary Logon' service must also be 'Manual' or 'Automatic'.

Share this post


Link to post
Share on other sites

In Computer Services check to see if

 

RetroLauncher

 

has 'Allow service to interact with desktop' checked in the 'Log On' tab.

 

I think 'Secondary Logon' service must also be 'Manual' or 'Automatic'.

 

The 'Retrospect Launcher' service on my PC is configured for automatic start with log on as 'Local System'. The Properties box for this service confirms that the 'Allow service to interact with desktop' checkbox for the local system account is already selected. However, the 'Secondary Logon' service was set to 'Manual' and was not started. I have now started this service and changed the startup type to 'Automatic'. I will check later to see if this fixes the problem. Thanks for your help. 

 

David

Share this post


Link to post
Share on other sites

Sadly, my changes to the 'Secondary Logon' service have made no difference. Retrospect still refuses to launch itself automatically to run a scheduled job. If I launch Retrospect manually after the scheduled start time then the delayed job immediately starts to run.

 

Where do I go from here?

 

David

 

 

Share this post


Link to post
Share on other sites

I would try starting the service manually to see if it will actually start.

 

The 'Retrospect Launcher' service is already started, as a result of being configured for automatic startup.

 

David

Share this post


Link to post
Share on other sites

I just tried configuring the Retrospect Launcher service  to use my normal log on credentials instead of using the 'Local System' log on option but it made no difference. 

 

David

Share this post


Link to post
Share on other sites

As an alternative you could try Windows task scheduler to launch Retrospect a few minutes before the scheduled start time of the backup.

 

Have you tried uninstalling and reinstalling Retrospect? I could be that the configuration of the Launcher Service has become corrupted.

Share this post


Link to post
Share on other sites

As an alternative you could try Windows task scheduler to launch Retrospect a few minutes before the scheduled start time of the backup.

 

Have you tried uninstalling and reinstalling Retrospect? I could be that the configuration of the Launcher Service has become corrupted.

 

I'll give both those suggestions a try. Thanks for the advice.

 

David

Share this post


Link to post
Share on other sites

I only discovered late last night that Retrospect Professional for Windows was now at V8.5 (I had been under the impression that my copy of Retrospect was configured for automatic updates and that V7.7 was therefore the latest version). In an attempt to fix my automatic scheduling issue, I immediately updated to V8.5. Sadly, however, it made no difference.

 

Retrospect tech support are now assisting me to track down the problem ...

 

David

Share this post


Link to post
Share on other sites

I am wrestling with this issue as well, so please post back when you find a solution. What has worked partially for me so far is to:

  • Configure the Retrospect Launcher service (retrorun) to login under my account instead of the default SYSTEM
  • Configure Retrospect to login as "current user" instead of explicitly specifying my account
  • Disabling UAC on the backup server

I have verified that Retrospect now launches automatically and runs the scheduled backup jobs successfully under my account. However, the full ui is not available for some reason, which is a real PIA. All I get is the totally useless little monitor window. I have no way to look at the current logs in progress, check on completion eta, or whether the job is prompting for media! Checking in task manager shows that Retrospect is running under my account, but the monitor window still says that "Retrospect is already running in another user's session". My next step is to see what happens if I have the full Retrospect UI always launched and open on the backup server, with "Stay in Retrospect" enabled.

Share this post


Link to post
Share on other sites

Hi dzeleznik,
The key thing that was preventing auto-launch of Retrospect was that I had Preferences/Execution/Security set to 'Always run Retrospect as the specified user'. I was advised by tech support that I had to change this to 'Run Retrospect as the logged-in user' and this solved my auto-launch problem. From what you say, you already appear to have made that setting.


Within Preferences/Execution/Startup I have chosen the Exit option for what happens after a backup job. I have no problem subsequently opening the full Retrospect UI.

David

Share this post


Link to post
Share on other sites

@haggis999- Thanks for the feedback. Yeah, I think something is foobar in my setup. I definitely have Retrospect set to Exit after a backup job with lookahead time of 1 hr. But when it is launched from the background retrorun service, it never exits. I have no scheduled jobs pending on the horizon, the retrospect.exe process is still running (quiescent with minimal memory and 0% cpu), only the retromonitor will launch from my interactive session. I have tried retrorun both logging in as my account and as the local system, but behavior is the same. For now, my only solution is to keep a login session active on the server and keep the full Retrospect gui running at all times. I'll contact support and see what they say.

Share this post


Link to post
Share on other sites

OK, here is what I do which has always worked for me - I have been using Retrospect for years ;) :

 

  • I leave the Retrospect Preferences as to the User at their default settings - I do not specify a User here.
  • I specify the Login Credentials of an admin / backup user account for the Retrospect Launcher service.
     

This means that when launching Retrospect unattended under a schedule the "User" of Retrospect is the “Logged In User” and that is my admin / backup user account.

 

The additional advantage for me is that the admin / backup user is also in my NAS' LDAP as an admin, so it also has access rights to all NAS' shares.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×