Jump to content
Sign in to follow this  
Don Lee

Retro 10.2 - performance boost?

Recommended Posts

I just upgraded to 10.2 today, and notice that in copying a media set, the copy speed is 2-3 times faster. (!)  Is this expected?  Where else can I expect (welcome) dramatic speed improvements?

Share this post


Link to post
Share on other sites

In some cases you will see large speed improvements when saving snapshot over the network.  This is noted in the release notes. 

Share this post


Link to post
Share on other sites

I can't agree - I'm working with Retrospect support on a dramatic slowdown in performance after installing 10.2 - 2.2 GB/minute down to c500-500 MB/minute in most cases. Not to mention the Retrospect engine maxing out a 2.3 GHz i7 running 4 simultaneous scripts (previously no problem)

Share this post


Link to post
Share on other sites

Just rolled back to 10.1 under advisement from support - backup speed and processor usage back to normal. Relief! Anyone else with a similar experience?

Share this post


Link to post
Share on other sites

... a dramatic slowdown in performance after installing 10.2 - 2.2 GB/minute down to c500-500 MB/minute in most cases. 

Your post sent me to our operations log, where I definitely ran into what is pretty clearly a bug in the way that both Retrospect 10.1 and 10.2 calculate their performance stats. It would seem that Retrospect must be subtracting the idle/loading/preparing time from the total duration, and using the remainder to calculate performance. However, there is often strangeness in that idle/loading/preparing time that suggests that Retrospect doesn't reset the start of that measurement when it accesses a source, but that it can also include the time spent in attempting to access sources that are not available on the network.

 

For example, see this log excerpt from Retrospect 10.1 that calculates an improbably optimistic performance figure for backing up Data Disk on client SXXX after spending a fair amount of time trying to access unavailable sources:

 

post-2992-0-30226400-1377290671_thumb.png

 

(The -519 errors are typical for client source volumes that were added by direct IP address and are not currently visible on the network.)

 

Here is another log excerpt for the same series of source volumes under Retrospect 10.2 that shows an absurdly poor performance figure:

 

post-2992-0-51920500-1377290672_thumb.png

 

Note that the "idle/loading/preparing" time is considerably longer than the total duration. I assume that the 0.1 MB/min performance, which seems to be the lowest possible in Retrospect, was defaulted to because the quotient would otherwise have been a negative number.

 

Clearly, one needs to look carefully at these supposed performance figures and not take them at face value.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×