Jump to content
EWTHeckman

Windows Client 8.1 not respecting Privacy

Recommended Posts

I'm running a Retrospect 10.1.0 (221) Server on a 10.6.8 Mac to back up a Windows XP client running Client 8.1.0 (266). One folder kept throwing errors due to the activity in it (anti-virus folder), so I decided to add that folder to the list of folders not to back up. It was added under the Client Privacy tab. But I'm still getting errors from that folder because Retrospect is apparently still trying to back it up.

 

There are currently two folders listed under the Privacy tab. A folder previously added under Retrospect Client 7.5 and the new folder. The old folder has backslashes for the path delimiters. The new one has forward slashes.

 

Any suggestions?

  • Like 7

Share this post


Link to post
Share on other sites

Try to retype the new folder path with backslashes. (I don't know if you can, I don't have that client version.)

Share this post


Link to post
Share on other sites

If you can't get the forward slashes changed to back slashes (Solidus and Reverse Solidus to give them their typographic names) there is a configuration file called RETCLIENT.DAT that can be edited. On Windows XP this file should be in the "C:\Documents and Settings\All Users\Application Data\Retrospect" folder. The file is a plain text file and can be edited with the Windows Notepad text editor (notepad.exe).

 

The file contains two entries for each folder to be made private. The first specifies the folder in long file name format and the second in 8.3 compatible file name format as in the example below:

I:\Images\Lightroom Catalogs\Main Lightroom 4 Catalog\Main Lightroom 4 Catalog Previews.lrdata
I:\Images\LIGHTR~2\MAINLI~1\MAINLI~1.LRD
To be on the safe side make a backup copy of the file before you edit it.

Share this post


Link to post
Share on other sites

Thank you both for your reponses.

 

Lennart, the client does not allow typing path names.

 

Scillon, the RETCLIENT.DAT was not within the Documents and Settings folder. I eventually found in it C:\Windows\. This may have changed for client 8.1. I made the change and tonight's backup should let me know if it fixes the problem.

 

Thanks again.

Share this post


Link to post
Share on other sites

Make sure that the backup server allows users to set client privacy. Sources>options. Make sure "exclude items from backup" is checked.

Share this post


Link to post
Share on other sites

Thank you, Robin. The option to allow client privacy was already on.

 

Scillon's suggestion fixed the problem, but not immediately. The first backup after editing the file still exhibited the problem. But after restarting the client computer the privacy setting was finally recognized.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×