Jump to content
mgf

error -597 ( mail server not found) but Pref E-mail test successful

Recommended Posts

In Retrospect for Mac 10.1, all backup operations (Mac, Windows, and Linux clients) return an "error -597 (mail server not found)" error. However, the E-mail test in my Retrospect preferences is always successful and I receive the test E-mail message every time. Very frustrating. Am I missing something? Anybody have any ideas?

Share this post


Link to post
Share on other sites

I have exact the same problem. In previous versions, there was no problem with e-Mails. Since 10.1 only the Test E-Mails are sent. All other notifications report Error -597.

If iCompute would please explain how to use tcpdump, this would help a bit...

Share this post


Link to post
Share on other sites

I also have the same problem. Testing email from Preference works fine, but I get

E-mail notification failed: error -597 ( mail server not found)

whenever a backup runs.

Share this post


Link to post
Share on other sites

I'm seeing exactly the same problem. Since the 10.1 update all emails fail with Error -597. The Test Messages go out OK. Under 10.0 the system emailed fine. 

Share this post


Link to post
Share on other sites

I am also seeing this problem, ironic since changes to email at my old ISP were the impetus to upgrade from R8. I did receive one status email from the most recent backup. All the rest failed. Is it possible that the timeout on contacting the server has been set too short?

 

My ISP requires an SSL connection for sending email.

Share this post


Link to post
Share on other sites

Thanks Charles. I tried that but didn't get anything useful. The log for last night's backup shows only "E-mail notification failed: error -597 ( mail server not found)" and the operations_log.utx doesn't show any entries more recent than 2000.

 

My mail server entry is in the form machine.domain.net:port. Could it be that Retrospect is choking on the (required by host) port?

 

Everything about this screams Bug! I am very annoyed that this has not been fixed by the 10.2 upgrade.

Share this post


Link to post
Share on other sites

Turns out that if you aren't getting your mail notifications you aren't missing anything. This is what they send.

 

Script: Laptops
Date: 7/24/2013
Script "Laptops" completed successfully

 

 

Seriously, that's it. I swear I didn't leave anything out. How this is possibly useful I can't even imagine. Which client of the 15 that are part of the script got backed up? How much data was copied? Mail reporting clearly needs some work.

Share this post


Link to post
Share on other sites

The latest Mac build 10.2.0.207 (with new email fixes since 10.2.0.201) is available through Support so that we can closely track if it fixes specific email notification issues.

 

In general for Retrospect:

  • For Gmail: On Windows, specifies port 465, i.e. smtp.gmail.com:465. On Mac, leaves out the port number and let Retrospect default to port 587.
  • For Exchange: Configure Exchange to disable TLS and enable Basic Authentication.
  • If port isn't specified and SMTP authentication is enabled in Retrospect's E-mail preferences, Retrospect defaults to port 587.
  • When unable to connect to the email server, Retrospect logs an error and then automatically fail over to a different method to try to connect. The interim error may appear in the operations log even when email is successfully sent after automatically failing over to a second connection method. For future release (v8.3 for Windows and v10.3 for Mac), we will log interim errors only if both connection methods fail.

Share this post


Link to post
Share on other sites

Thank you, David.

 

I contacted tech support and installed the new build. Unfortunately, I'm still getting the error. I've notified tech support.

Share this post


Link to post
Share on other sites

We have had the same problem.

 

Retrospect Server:

Mac Mini 2Ghz Intel Core 2 Duo

2GB 1067MHz DDR3

Retrospect server 10.2.0 (201)

 

Mail Server:

Mac Mini 2.66Ghz Intel Core 2 Duo

OSX Server 10.6.8

Kerio Connect 7.4.3 build 7813.

 

The Kerio Connect software is our "Exchange Like" mail server. Following the previously posted recommendation, I turned off TLS in the smtp services and everything started working fine. 

 

To do so:

1. Log into your Kerio Admin Console

2. Go to Configuration -> SMTP Server

3. Click on the SMTP Delivery Tab

4. Uncheck the option for "Use SSL/TLS if supported by remote SMTP server"

5. Click Apply, and close the Admin console

 

Note: This is what Kerio says the setting is for...

"Use the following steps to route outbound mail from the Kerio Connect Mail Server through the Barracuda Spam & Virus Firewall."

http://techlib.barracuda.com/pages/viewpage.action?pageId=3866685

 

This is what Microsoft says about SSL/TLS...

http://technet.microsoft.com/en-us/library/cc784450(v=ws.10).aspx

 

It would seem wise to have SSL/TLS enabled on your mail server. I do not think it is a good idea to turn it off because Retro is unable to use it properly.

Share this post


Link to post
Share on other sites

 

The latest Mac build 10.2.0.207 (with new email fixes since 10.2.0.201) is available through Support so that we can closely track if it fixes specific email notification issues.

 

In general for Retrospect:

  • For Gmail: On Windows, specifies port 465, i.e. smtp.gmail.com:465. On Mac, leaves out the port number and let Retrospect default to port 587.
  • For Exchange: Configure Exchange to disable TLS and enable Basic Authentication.
  • If port isn't specified and SMTP authentication is enabled in Retrospect's E-mail preferences, Retrospect defaults to port 587.
  • When unable to connect to the email server, Retrospect logs an error and then automatically fail over to a different method to try to connect. The interim error may appear in the operations log even when email is successfully sent after automatically failing over to a second connection method. For future release (v8.3 for Windows and v10.3 for Mac), we will log interim errors only if both connection methods fail.

 

Hi, David.

 

Surely it would be a good idea if something like this was in the manual? Especially what the default port settings are with/without authentication. It would also be a good idea if the manual said that Retrospect can't connect to SMTP servers using a secure (SSL/TLS) connection. Or even better, implement secure SMTP connections.

 

In the documentation for my preferred SMTP server, Yahoo, says that it only supports SSL/TLS connections for SMTP connections. It appears that that isn't actually true, but it's still my preferred connection method. Why should email authentication password and the contents of my emails be unnecessarily exposed on the net?

Share this post


Link to post
Share on other sites

Now they just need to make the email messages it sends more useful buy including the name of the client or even better by sending a daily summary of all backup activity. When you're backing up 15-20 clients among multiple locations, the emails sent by Retrospect aren't terribly useful in their current state.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×