Jump to content
roland1

Backing up to offsite locations

Recommended Posts

I have not been able to find any clear instructions on how to use Retrospect 10 for Mac to backup to remote, offsite location. I downloaded and set up live drive and followed the instructions in retro help but it does not work. Below is the log. Has anyone successfully done a Webdav backup before? is there a cloud service that retro will work with? I am happy with the program and it does what I want it to do on my local network perfectly but there are files that I wish to backup offsite also.

 

 

+ Normal backup using New Script at 2013-02-17

To Backup Set

Media Set A... - 2013-02-17 7:06:05 PM: Copying Safe Database copies Using Instant Scan MapError: unknown Mac error 60 TFile::Flush: fsync failed, /Volumes/webdav.livedrive.com-2/Retrospect/Media Set A/1-Media Set A/AAd.rdb, oserr 60, error -1002 MapError: unknown Mac error 60 TFile::Flush: fsync failed, /Volumes/webdav.livedrive.com-2/Retrospect/Media Set A/1-Media Set A/AAd.rdb, oserr 60, error -1002 MapError: unknown Mac error 60 TFileLoc::Lock: UGetFileMode failed, /Volumes/webdav.livedrive.com-2/Retrospect/Media Set A/1-Media Set A/AAd.rdb, oserr 60, error -1002 MapError: unknown Mac error 60 TFolderLoc::StartFind: UFindFirstFile failed, /Volumes/webdav.livedrive.com-2, oserr 60, error -1002 MapError: unknown Mac error -1401 TVol::GetInfo: UGetVolumeInformation failed, /Volumes/webdav.livedrive.com-2/, oserr -1401, error -1002 MapError: unknown Mac error 60 TFolderLoc::StartFind: UFindFirstFile failed, /Volumes/webdav.livedrive.com-2, oserr 60, error -1002 MapError: unknown Mac error 60 TFileLoc::GetInfo: UFindFirstFile failed, /Volumes/webdav.livedrive.com-2/Media Set A.rbc, oserr 60, error -1002 MapError: unknown Mac error 60 TFolderLoc::StartFind: UFindFirstFile failed, /Volumes/webdav.livedrive.com-2, oserr 60, error -1002 MapError: unknown Mac error -1401 TVol::GetInfo: UGetVolumeInformation failed, /Volumes/webdav.livedrive.com-2/, oserr -1401, error -1002 MapError: unknown Mac error 60 TFolderLoc::StartFind: UFindFirstFile failed, /Volumes/webdav.livedrive.com-2, oserr 60, error -1002 MapError: unknown Mac error 60 TFile::Create: UCreateFile failed, /Volumes/webdav.livedrive.com-2/Rtrd.tmp, oserr 60, error -1002 MapError: unknown Mac error -1401 TVol::GetInfo: UGetVolumeInformation failed, /Volumes/webdav.livedrive.com-2/, oserr -1401, error -1002 !Can't save Catalog File, error -1002 ( unknown Mac OS error) 2013-02-17 7:08:34 PM: Execution incomplete Completed: 8 files, 67 MB Performance: 45.1 MB/minute Duration: 00:02:28 (00:00:59 idle/loading/preparing) MapError: unknown Mac error 60 TFile::Create: UCreateFile failed, /Volumes/webdav.livedrive.com-2/Rtrd.tmp, oserr 60, error -1002 MapError: unknown Mac error -1401 TVol::GetInfo: UGetVolumeInformation failed, /Volumes/webdav.livedrive.com-2/, oserr -1401, error -1002 !Can't save Backup Set Media Set A, error -1002 ( unknown Mac OS error) MapError: unknown Mac error 60 TFolderLoc::StartFind: UFindFirstFile failed, /Volumes/webdav.livedrive.com-2, oserr 60, error -1002 MapError: unknown Mac error -1401 TVol::GetInfo: UGetVolumeInformation failed, /Volumes/webdav.livedrive.com-2/, oserr -1401, error -1002 MapError: unknown Mac error 60 TFolderLoc::StartFind: UFindFirstFile failed, /Volumes/webdav.livedrive.com-2, oserr 60, error -1002 MapError: unknown Mac error -1401 TVol::GetInfo: UGetVolumeInformation failed, /Volumes/webdav.livedrive.com-2/, oserr -1401, error -1002 MapError: unknown Mac error 60 TFolderLoc::StartFind: UFindFirstFile failed, /Volumes/webdav.livedrive.com-2, oserr 60, error -1002 MapError: unknown Mac error -1401 TVol::GetInfo: UGetVolumeInformation failed, /Volumes/webdav.livedrive.com-2/, oserr -1401, error -1002 MapError: unknown Mac error 60 TFolderLoc::StartFind: UFindFirstFile failed, /Volumes/webdav.livedrive.com-2, oserr 60, error -1002

Share this post


Link to post
Share on other sites

That was just part of the troubleshooting. So it indeed looks like it is a bug in Retrospect. Please contact Retrospect support.

 

EDIT:

This is what the error means:

 

 

errFSBadFSRef = -1401, /* FSRef parameter is bad */

 

https://github.com/openframeworks/openFrameworks/blob/master/libs/quicktime/include/MacErrors.h

 

(FSRef is an internal data structure in a program to access a file. It seems as Retrospect doesn't create the data structure correctly.)

Share this post


Link to post
Share on other sites
So it indeed looks like it is a bug in Retrospect

 

I wouldn't go there before knowing the steps that were taken that resulted in the error. I'm the first person to recognize that WebDAV support in Retrospect isn't as robust as it needs to be, but I also recognize that user error is a very common cause of Retrospect problems.

 

I went ahead and signed up for a Livedrive Briefcase, which provided an application that handled authentication and mounting of the storage volume (shown as /Volumes/LivedriveFS on my filesystem). Attempts to connect using the Finder to http://webdav.livedrive.com using my account email and password were unsuccessful.

 

So the question becomes, how did you configure Retrospect to access the destination volume you were attempting to use as the Destination for (what I must assume to be) your Disk Media Set?

Share this post


Link to post
Share on other sites

Since the fine folks at Livedrive seem to think it's necessary to withhold access to their knowledge base articles to non-subscribers, I needed to sign up for a trial account to learn that direct WebDAV access is only available to their higher tier "Pro" accounts.

 

Having complete steps to reproduce will likely reveal it's a path name issue, but we'll need additional information to find that out.

 

-dave

Share this post


Link to post
Share on other sites
I can mount the volume in finder and copy data there from finder but cannot use retro to copy data there.

 

But it's Retrospect that's not working, so knowing the actual steps you have taken to configure Retrospect would be necessary for other Forum contributors to offer a solution.

 

Mounting a share point in the Finder that you also want to use as a Retrospect Source is the most common mistakes Retrospect users make, and the volume name you provided (about which I previously requested confirmation) is another clue that your software setup is the cause of the failures.

 

Feel free to provide more complete information; it's what will lead to an answer and an explanation of your experience. But I'm not feeling this as a software defect.

 

-dave

Share this post


Link to post
Share on other sites

I get the exact same errors backing up to a WebDav source.

 

I can mount it fine, can copy files to it fine. I have Retrospect 10.2. It starts off backing up okay but after about 20Gb or 30Gb into it I have about 10 of these MapError: unknown Mac error 60 TFile::Flush: fsync failed, /Volumes/webdav.livedrive.com-2/Retrospect/Media Set A/1-Media Set A/AAd.rdb, oserr 60, error -1002

 

Eventually it gets hung up and Retrospect looks like it's still backing up but nothing is happening. I try to stop the script but won't stop. Have to force quit and repair the catalog. (Which repairing works, it finds the data and repairs it no problem)

 

I've sent my logs to Retrospect. Hopefully this can be solved soon. I'm using this WebDav server as my offsite backup and ready to dump several TBs of data to it.

 

Dana

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×