Jump to content
Sign in to follow this  
davidduff

retrosect10: console instability

Recommended Posts

i'm running retro v10 console on my server, connected to the local retro engine and roughly every 5 mins, the console "blanks out", acting as though it has just restarted itself. it jumps up to the top level default display.

 

from the log view within the retro console app, it appears that this is happening every 5 mins give or take a few seconds, with occasional "skips" where the interval is roughly 10 mins. in the console log view, i also see one odd msg of the form: "StucOpen: IOCreatePlugInInterfaceForService(kIOMMCDeviceUserClientTypeID) (error -536870210)".

 

also, i had been away for a while and came back to the machine to find the console app had crashed. i have the crashdump and can post if it is useful.

 

in this situation i'm running the latest retrospect v10 console and engine (installed ~4 days ago). the retro engine is running locally on the same box as the retro console. my system is running mac os x 10.6.8 server.

 

in the system console on the machine, i see bunches of msgs at 5 minute intervals of the form "Server::updateScriptsCache exception: MacRequestor::Request: connection closed by remote endpoint" or " and other similar msgs involving updateSetsChangeCounter, updateSelectorsCache, etc. i'll post these log records as an attachment - it actually looks like there might be a lot of different things going on there that don't look familiar, including some scary-looking assertion failures - hmmm...

RetroEngine or Retrospect.txt

Share this post


Link to post
Share on other sites

well, it looks like i misread the situation, and thus the title of this post is misleading. my engine is crashing every five minutes. i don't know the actual root cause, but it seems likely that whatever the problem is, it is likely that is not the fault of the console or engine-console comms as i incorrectly assumed.

 

refer to a separate forum thread i've opened under the heading "retrospect10: retroengine assertion failure at grx.cpp-1098".

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×