Jump to content
Sign in to follow this  
MarkF2748

Retrospect Pro for Windows 8?

Recommended Posts

I've been using Retrospect since 2006 on a small network of Windows PCs and workstations, currently all Win 7 and Retrospect Pro 7.7. Over time, I've come to really appreciate the flexibility and power of this backup solution.

 

Will there be a Retrospect Pro for Windows 8, especially given the new backup options built into Windows 8? Does the current Version 7.7 for Windows work on a Windows 8 host in a mixed Win 7/Win 8 client environment?

Share this post


Link to post
Share on other sites

Retrospect 7.7 does support Windows 8, but it does not support the new Windows 8 Disk Spaces feature.

 

Well, that appears not to be quite true. The Retrospect Client cannont be found unless a user is actually logged in. If I start up a Windows 8 Pro PC and leave it at the Lock Screen then my Retrospect backup PC cannot find the client. If I log in to the Start Screen it can. But this is not a workaround for me as I have my client PCs start up (from the BIOS) at night for my backups to run.

 

I have even created a task to fire up the Retrospect Client at Windows 8 Startup, but no joy.

 

EDIT: Additionally it is not "aware" of the Windows 8 swapfile and a Compare warning occurs: File "C:\swapfile.sys": didn't compare.

 

EDIT: It looks like the new Retrospect Windows Professional Version 8 may fix this problem with a new client. I have asked Support to confirm this.

Edited by Colin F

Share this post


Link to post
Share on other sites

Win 8 host data point:

I've been running Retrospect 7.7 host on a Win 7 32-bit PC. When that PC was upgraded (i.e. not clean install) to Win 8 32-bit, then Retrospect continued to work as if nothing had changed (like all my other applications so far). The clients are Win 7 32-bit and 64-bit on a wireless network.

Share this post


Link to post
Share on other sites

MarkF2748,

 

Good to know that Retrospect Professional runs OK on Win 8. I run Retrospect Professional on a Win 7 64 bit PC that is dedicated to unattended backups (overnight). I recently upgraded my main workstation PC (not a clean install) from Win 7 Pro 64 bit to Win 8 Pro 64 bit. This PC has a Retrospect Client (installed under Win 7) which now fails to connect to the backup PC running Retrospect Professional following the upgrade when powered on but with no user logged in. When a user is logged on the Retrospect Client is found OK. So it is a Retrospect Client / Windows 8 problem.

 

I note with the latest Retrospect Professional 8 release there is a new Retrospect Client. I have a question into Support to confirm this issue is fixed.

Share this post


Link to post
Share on other sites

Is it a client issue...or did Win 8 change a setting to not allow access unless logged in?

It almost seems like a security issue.

 

I'm interested to hear this, we're getting ready to roll out Win8 to some folks.

Share this post


Link to post
Share on other sites

Colin,

 

As a basic sanity check, have you tried to ping the Win 8 client from a command prompt, view it on a network map, or look for it with "net view", just to determine whether the machine is visible on the network, independent of Retrospect? If a client fails the ping test, then Retrospect never sees it and errors out on backing up that client. The visibility to Retrospect can also be checked with Retrospect > Clients > Properties > Volumes.

 

I find that my Win 8 Pro installation does not auto-connect to the network and does not remember a default network name and password. I must fill these in manually each time I first log into my user account to establish network connectivity. This annoyance could be due to an old driver for my wireless USB adapter (6-year-old Linksys WUSB54G) on the desktop. In general, there is a lack of guaranteed wireless USB adapters/drivers for Win 8 at this time. Also, MS is reported to have made substantial changes to the networking components under the hood, so there may be some bugs lurking. Once I log in, everything is fine and the connection survives sleep/wake up as long as power save is disabled for the adapter.

Edited by MarkF2748

Share this post


Link to post
Share on other sites

MarkF2748,

 

For a number of other reasons I have already restored the upgraded PC back to Win 7 Pro, so currently I am unable to perform these tests - although they are good suggestions. As an aside, I found that going back to Win 7 messed with my data disks (a very long Chkdsk session was required of ~36 hours) so I am not keen to experiment further until I can isolate them :-). I do know that Retrospect Professional claimed not to be able to connect to the Retrospect Client and no Volumes were visible.

 

My network is all wired 1 Gbit, but at the lock screen you could well be right that the network connection is not yet established. If that is so, it is hard to see how unattended, timed backups can ever work.

 

Good to know that sleep does not mess up a backup if the network card's power save is disabled.

 

I hope to try your suggestions at the weekend when I have the time to mess with this all again and will report back.

Share this post


Link to post
Share on other sites

I will be testing a machine today.

 

Fresh install of Windows 8 with Retrospect 7.7 installed.

 

This was the machine I tested the install/backup/restore on....all went well.

 

I'll restart the machine and NOT log in. Try ping and a number of other things.

Share this post


Link to post
Share on other sites

I had the Win8 machine on line and could ping it and connect to the admin share...as well as add it with the DNS name, into Retrospect on the server.

Will see if I can run a backup while the user is not logged in.

Share this post


Link to post
Share on other sites

Further investigation with my Linksys-Cisco WUSB54G Ver.1 wireless USB network adapter (driver wusb20xp.sys Ver. 1.0.8 (2004)) using WEP security and Windows 8 Pro (Ver. 6.2.9200 Build 9200):

 

When router broadcasts with SSID hidden there is no automatic connection to the wireless network by Win 8. I must log into my user account and then manually log into the network (enter SSID and WEP key), after which the connection survives until the next reboot.

 

When router broadcasts unhidden i.e. visible SSID, then the Win 8 pc automatically connects to network as desired with no user interaction (after key has been entered once and set for automatic connection).

 

As a further test of router broadcasting with hidden SSID, I rebooted pc and let it sit at the login prompt (no user intervention). Another pc tries to ping it, but ping fails. I then change the router to broadcast with unhidden SSID. The pc immediately responds to ping.

I never had these issues with the same network and hardware running Win 7 and router always broadcasting with hidden SSID.

 

Others report this issue, for example at http://social.techne...a9-c59edf9f69ef where I also just posted my experience.

Edited by MarkF2748

Share this post


Link to post
Share on other sites

Yes, but from Colin's report above, it is possible that the same issue may apply to wired networks (I cannot test a wired scenario).

 

BTW, I easily changed the WUSB54G from WEP to WPA+AES using the current Win 8 driver (WPA2 does not appear as an option for the WUSB54G Ver. 1). So with broadcasting unhidden SSID and a strong encryption password we are good to go here, at least until a cost effective WPA2 adapter is reported to work with Win 8 :<)

 

Aside: In Win 7, when router broadcasts with hidden SSID the SSID is nevertheless visible to the end user for selection, or the connection can be made automatically based on order in the user-managed network list. In Win 8 when router broadcasts with hidden SSID the network is invisible in the charms GUI and there is no user-managed network list. The Win 8 user must know this network's SSID as well as key and enter them manually each time to connect. A checkbox option to connect automatically to a network with hidden SSID is available but seems to be functionally broken (at least with my router). On the other hand, if network broadcasts unhidden SSID it appears explicitely in the Win 8 charms GUI and user only needs to select the SSID from list and enter the key. In this case selecting automatic connection indeed assures that future connections are made without user intervention.

Edited by MarkF2748

Share this post


Link to post
Share on other sites

Once I log in, everything is fine and the connection survives sleep/wake up as long as power save is disabled for the adapter.

 

Update: When wireless router broadcasts with unhidden SSID, the pc reconnects immediately upon wakeup from sleep (by tapping keyboard), even with USB and network card set for max power save during sleep.

Edited by MarkF2748

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×