Jump to content
darkod

network communication failed error 519

Recommended Posts

Hi all. I have used earlier version of Retrospect for Windows to backup a network, around the 2005-2006 period.

 

I want to suggest Retrospect to the company I am currently working at and I have downloaded the latest 7.7 trial version for Windows.

 

After an initial couple of backups that finished successfully including all three storage groups of the Exchange 2007 server, I keep getting the error 519 on almost every try. Two different clients and 5-6 different configured volumes. What is going on?

 

The copy process starts good, and then it stops, never after the same time has passed. The most recent for example, stopped at only 322MB copied of a 11GB storage group. It has done the same storage group only once, only the first time successfully, and later it fails at 6Gb done, 3GB done, now at only 322MB done, etc.

 

The connection between the backup server and the client servers (tried only two clients so far) is very simple in this case, they are all connected to the same Gb switch. So there is very little reason to actually suspect the network connectivity itself.

 

Two cables (backup server to switch, client server to switch) and the switch itself. Nothing else. The cables are brand new and very good quality. The servers work as normal in the network, no complaints from users, nothing. Including the Exchange which is on all of the day and hasn't failed once. However, Retrospect keeps complaining with error 519.

 

I have tried removing the clients, and installing them again. Today I even removed Retrospect and installed it again, same thing.

 

The switch is kind of older model of 3Com and I was suspicious, but to rule it out I used a small desktop Gb switch for just the backup server and one client server. It failed again. On the 3Com I can't see any real CRC errors or collisions on the ports where these servers are connected. Nothing that would make me really suspicious about the switch, except that it is a bit older 2924 model.

 

I tried to Google around but didn't find much except that error 519 is very difficult to diagnose...

 

Anyone has any ideas or I will have to look somewhere else for my backup solution which would be a real shame after the excellent experience I had with Retrospect the last time. And I really like the interface and how it does things.

 

But throwing error 519 out of the blue and no obvious way to solve it or find the reason is a bit too much. I need to depend on it. Any ideas and tests I can run are welcomed. Thanks in advance.

Darko.

 

PS. Smaller backups seem to go fine. Can it be that it is really moving that much data on the big backups that the old 3Com is blocking itself? But wouldn't I see more collisions, or CRC errors, or what ever in the port statistics of the switch in that case? Just for an idea, the storage groups are like 150GB, 11GB and 100GB. Volumes with files are like 190GB, 244GB, 130GB.

But that shouldn't be a big deal for a backup software.

  • Like 1

Share this post


Link to post
Share on other sites

You get the -519 error when the network connection is lost. The most common reason is when a user disconnect their laptop in the middle of a backup and runs off (with the laptop).

 

The fact that the cables are new doesn't guarantee they are fault-free. Try another set of cables.

 

Also make sure all the drivers are updated, especially for the network cards. Some cards even has updatable firmware. You should check that as well.

 

EDIT: When trying another set of cables, try to avoid using the same brand (or at least not using the same batch).

Share this post


Link to post
Share on other sites

Well, as I said these are servers so there is no chance of disconnect and run off.

I know the cables being new doesn't guarantee anything but on the other hand it's much better than old cables crimped in a curious way. If it is a cable issue i would expect to see much more complaints from users, especially on the Exchange server which has like 15 people connected to it all the time with their Outlook and working a lot in public folders all the time. All of this works fine, but not the Retrospect backup that suddenly decides it has no network connectivity. Strange...

Share this post


Link to post
Share on other sites

Did you check the drivers and the firmware?

 

Let me tell you a story:

In our old office we had a client computer that refused to be backed up. I don't remember what the Retrospect error was, but it wasn't backed up. In all other respects, the client worked fine. Copying files to/from servers, using email, browsing the web, you name it. It was only Retrospect that didn't work.

It turned out that it was the network contact in that office that was bad. It worked for "normal" access. But Retrospect has more demand for bandwidth than just file sharing or Exchange, so the connection simply failed. Plugging the computer into the network outlet in the next office solved the problem.

 

Let me tell you another story:

We had one database server that seemed to work fine. But Retrospect didn't work. It turned out to be caused by old NIC drivers.

Share this post


Link to post
Share on other sites

I am aware of that, and my suspicion is also that it fails once it starts to demand large bandwith. But of coure, that is so difficult to prove. And why i suspect the switch as a primary suspect. i think it simply doesn't pass the packets fast enough from one port to the other.

 

On one server i am about to install the latest Broadcom Management software in the next few days, I guess that will install the latest drivers too. I will use the possibility to see if that changes anything. I will double check drivers.

 

The other thing is that these are production servers and I can't simply take them offline to check cables etc, unless I really have something pointing that way. Not just fishing around. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×