Jump to content
f35007e7-9d23-42ec-b5af-6466da5207c3

Frequent crashes from elem.cpp-1138 assertion

Recommended Posts

Running Single Server, 7.7.620. Recently, Retrospect has started crashing every couple days from this error: Assertion failure at "elem.cpp-1138"

I did see mention of that related to tape devices in some release notes, but we aren't using any tape devices with Retrospect.

 

Any solutions to this?

Share this post


Link to post
Share on other sites

An assertion error usually means a file got corrupted. The best course of action is to uninstall and re-install. You should not lose any of your settings, backups sets, scripts, etc. If you want to be on the safe side make a copy of the setting files Config77.bak and Config77.dat. These might be named Config75.bak and Config75.dat, respectively.

Share this post


Link to post
Share on other sites

i have the exact same error on single server .

when i tried to re install the latest version (Retro_EN_77562.exe) on xp ro x 64 i get

>> install internal error 2753

is there any fix and update ?

Share this post


Link to post
Share on other sites

We too are receiving this error at least once a week.

Scripts will run faultlessly for day after day and then.....

 

Assertion failure at "elem.cpp-1138"

 

We do keep sending the error report to Retrospect, but is anything actually done with it?

 

Retrospect 7.7.620

MS SBS2003

 

We (well, the end user) back up to usb drives and there seems to be a trend that if they forget to change the drive this error is likely to occurr, although it doesn't happen every single time they forget.

 

I note this topic is a month or two old, now, but did anyone ever make any progress?

Share this post


Link to post
Share on other sites

I too had the assert failure:

 

Exception occurred on 9/24/2012 at 2:54:24 PM

Error info: Assertion failure at "elem.cpp-1138"

Exception code: E0000000 ASSERTION

Fault address: FD4ACACD 0001:0000BACD KERNELBASE.dll

 

This happened when I attempted to delete all execution history.

 

I'm also running V7.7.620.

Share this post


Link to post
Share on other sites

I have seen this error frequently. Re-install hasn't helped. Running Multi-server v7.7.620. I just saw it happen while absolute nothing was going on. Retrospect wasn't executing a thing.

Share this post


Link to post
Share on other sites

Try moving away your current configXX.dat to save it, and then restore an older one or letting Retrospect create a new empty one. If Assertion failure at "elem.cpp-1138" still occurs, please contact Support so that we can work with your specific situation. Thanks.

Share this post


Link to post
Share on other sites

I get this nightly using RS 8.0 Multi Server - seems to be groom related.

 

It's a shame when you need more intensive backups for your backup system than the systems we're trying to protect with it...

 

Rich

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×