Jump to content
theboyk

"Enable Wake-on-LAN" not waking OS X 10.7 clients for regular backups?

Recommended Posts

I just added my first three OS X 10.7.4 clients to Retrospect 9 (latest versions installed for both client/server) and none of them wake from sleep when a backup runs (regular backup). The only mention of this functionality is in the Retrospect 8 documents where it says:

 

"...Enable Wake-on-LAN if you want to make sure that Retrospect wakes up a sleeping client computer for Proactive Backup activities..."

 

Does this mean Wake-on-LAN only works when doing Proactive backups and doesn't work during regular backups?

 

I'd like to have the ability for our machines to go to sleep at the end of the day, but still back up when regular backups run later that night.

 

Thanks,

Kristin.

Share this post


Link to post
Share on other sites

The "Wakeon lan" feature has to be enabled on the machine. Check out the system prefs -> energy saver -> options -> "Wake for Ethernet network administrator access".

 

I believe that a similar option exists on Windows.

Edited by iCompute

Share this post


Link to post
Share on other sites

The "Wakeon lan" feature has to be enabled on the machine. Check out the system prefs -> energy saver -> options -> "Wake for Ethernet network administrator access".

 

I believe that a similar option exists on Windows.

 

They've always been set...but not working.

 

I'll see if I can find the data from 'support' about it not working.

Share this post


Link to post
Share on other sites

Same here — I have WOL set on all of our machines as that's how I get Apple Remote Desktop to wake them easily when I do remote updates, deployments, etc. after hours. So, WOL works, just not with Retrospect.

Share this post


Link to post
Share on other sites

Not sure about Retrospect 9, but it seems to be working for me on Retrospect 7.7 for Windows (Single Server, Windows 2003 SBS) with Mac clients. We are using a Proactive Backup script.

 

However, I've only had it enabled for the last couple of weeks. A small number of backups have been missed, but I'm not sure whether that's due to WOL not activating or some other issue. I'm hoping to test it a bit more thoroughly soon, so will post here if I learn anything that may be of interest.

Share this post


Link to post
Share on other sites

Well, for me it's Retrospect 9 (unlimited server, on the Mac) and all 35+ clients are Macs (some 10.5, most 10.6, some 10.7) and I can't get WOL working on regular backups.

Share this post


Link to post
Share on other sites

Today I tested our Windows client by putting it to sleep before its backup time, and Retrospect woke it up without any problem. As with the Macs, I am using a Proactive script to backup this machine.

 

I have not tried it with a regular script, because I recall reading in the forums that it is only supported for Proactive backups. (Having said that, I also recall reading what Mastercam mentioned above, about the feature being visible in the GUI but not enabled in the code... evidently, this is not the case! I wish I had tried it out sooner.)

 

Since the Mac v8 documentation only mentions it into relation to Proactive backups, I would guess that a Proactive script is the only way to make it work. Have you (theboyk) tried a Proactive script?

Share this post


Link to post
Share on other sites

By the way, here is a free, easy-to-use Mac program that can be scheduled to wake computers up at particular times:

 

http://www.readpixel.com/wakeonlan/index.html

 

If a Proactive backup script is not suitable for your needs, maybe you could install this on the same computer as Retrospect, and schedule it to wake each computer 5 minutes before its scheduled backup time?

Share this post


Link to post
Share on other sites

Retrospect WOL has never worked for me (or at least not in a very long time) on any version of Windows client - and not on Win7 or Win8 clients even now. I can send a WOL from any number of LAN utilities I have and wake up the computers, but Retrospect cannot seem to do it. PITA!

Share this post


Link to post
Share on other sites

I just added my first three OS X 10.7.4 clients to Retrospect 9 (latest versions installed for both client/server) and none of them wake from sleep when a backup runs (regular backup). The only mention of this functionality is in the Retrospect 8 documents where it says:

 

"...Enable Wake-on-LAN if you want to make sure that Retrospect wakes up a sleeping client computer for Proactive Backup activities..."

 

Does this mean Wake-on-LAN only works when doing Proactive backups and doesn't work during regular backups?

 

I'd like to have the ability for our machines to go to sleep at the end of the day, but still back up when regular backups run later that night.

 

Thanks,

Kristin.

I found this information about setting Wake-On-LAN (WOL) in Apple's KB. Now the question, does Retro 10 (or 9 for that matter) fully support Bonjour based WOL as used in Mac OS X for Lion and later, particularly Mavericks (10.9)? I think not!

 

According to what is in the KB above, wireless clients should be supported through use of Airport base stations' Proxy Service (which in my case is exactly what I'm using and what is enabled per the KB). My wireless client DOES NOT get awoken by Retro when computer is sleeping, e.g., when the setting (System Preferences>Energy Saver)  to computer sleep X minutes, where X is less than "never sleep" and that time expires.  My work around is setting the computer (laptop's energy Save mode) to never sleep when plugged into power. Is there another way? 

 

And yes, for this to work, the clients' setting to WOL is (and does need to be) enabled and can be easily checked as described for all OS X installation since Lion. 

 

The computer wakes just fine in its "default setting" by other means (non-Retro) - via other machines, apps like iTunes or Screen Share, Utilities like Ping. Why not Retro? The error this generates using Retro is a 519 error, "...not accessible." Whether ProActive Backup or other backups are used is irrelevant to this issue when using the described proxy server. YMMV using other wireless based devices. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×