Jump to content
Sign in to follow this  
henry-in-florida

Multiple Activity Threads (Retro Desktop) in Retro 9

Recommended Posts

Was told that Desktop should support Multiple Activity threads vs. Retro 8 which reset itself from a higher number down to 1 continuously. Well, it does, sorta. In Retro 9.02, when the Host machine is restarted, the Activity thread setting is still returned to 1. The good news is that during other times the setting does stick.

 

Any way to keep it where it is when the machine is restarted.

 

Thanks,

 

Henry

post-45724-0-04946100-1340020161_thumb.png

Share this post


Link to post
Share on other sites

Try stopping the engine via the system preference rather than just restarting the Engine computer. A clean stop of the engine will force any cached writes to the config80.dat file.

 

An OS restart of the engine computer might not do this all the time (depending on what was going on with the engine computer...)

  • Like 1

Share this post


Link to post
Share on other sites

Try stopping the engine via the system preference rather than just restarting the Engine computer. A clean stop of the engine will force any cached writes to the config80.dat file.

 

An OS restart of the engine computer might not do this all the time (depending on what was going on with the engine computer...)

Good idea. I'll give it a try. It used to be a problem with 8.x and was entirely random, always resetting to default (1) on it's own. I'm pretty sure I tried restarting the Engine, but that led to other issues... The Multi-Server demo of course had no such issues. I thought they had it fixed. It might still be but maybe not? Have you experienced this issue?

 

Henry

Share this post


Link to post
Share on other sites

I have not experienced this issue. I have always (at least as far back as I can recall) had this value set to the maximum (currently it's set at 16). I've never had this revert back to a lower number unexpectedly...

Share this post


Link to post
Share on other sites

I have not experienced this issue. I have always (at least as far back as I can recall) had this value set to the maximum (currently it's set at 16). I've never had this revert back to a lower number unexpectedly...

 

Then I bet you aren't using Desktop Backup.

 

I turned off the Engine as you suggested. When I turned it on again, and opened the Retro Console app it was back to 1, the default and after resetting stays at 2 or wherever it's set. The Multi-Server (demo) setting in not like that in that it stays at 4, I think as the default. Why doesn't the Desktop stay where it's set in Preferences?

 

Henry

Share this post


Link to post
Share on other sites

Was told that Desktop should support Multiple Activity threads vs. Retro 8 which reset itself from a higher number down to 1 continuously. Well, it does, sorta. In Retro 9.02, when the Host machine is restarted, the Activity thread setting is still returned to 1. The good news is that during other times the setting does stick.

 

Any way to keep it where it is when the machine is restarted.

 

Thanks,

 

Henry

I've never been able to make multiple activities work in Retro Desktop, either. Sometimes the setting appears to stick, but every time I try to schedule parallel jobs, I see that it's been set back to 1.

 

The Fine User's Guide offers a hint why:

Desktop 3-User backs up a single machine and two clients (Mac, Windows, or Linux), and it includes open file backup for Windows XP and Vista clients. This license will not back up a server, such as Mac OS X Server or Windows Server, and is limited to a single activity thread [my emphasis].

 

In Retro 9, the number of clients is increased to four, but I don't think multiple activities have been allowed.

Share this post


Link to post
Share on other sites

I've just done some testing on Retro 9 Desktop. The number of activity threads is set back to 1 if the Engine is restarted. This happens even if the Console stays running. The number of activity threads can stay at more than one if the Console is restarted without restarting the engine. If the preference panel stays open in the Console while the engine is restarted, the Activity Threads setting appears unchanged, until the Preferences panel is closed and re-opened.

 

However, even if the preference setting for Activity Threads is > 1, if I start more than one activity, only one runs at a time. Changing the Activity Threads setting, even if can be made to "stick," doesn't appear to actually achieve anything.

 

Given that the User Guide says that multiple activity threads aren't supported on Desktop, these bugs appear to me to be cosmetic. As I wrote before, the Activity Threads preference should probably be either disabled/greyed out or omitted completely in Desktop.

Share this post


Link to post
Share on other sites

However, even if the preference setting for Activity Threads is > 1, if I start more than one activity, only one runs at a time. Changing the Activity Threads setting, even if can be made to "stick," doesn't appear to actually achieve anything.

 

Given that the User Guide says that multiple activity threads aren't supported on Desktop, these bugs appear to me to be cosmetic. As I wrote before, the Activity Threads preference should probably be either disabled/greyed out or omitted completely in Desktop.

 

I have seen multiple threads execute simultaneously when there pref is set to >1. Try an experiment. With the preference set >1, try to back up two scripts (or instant backups) using DIFFERENT Sources and DIFFERENT Media Sets. See if they execute simultaneously. Multiple threads worked in Retro 8. The User Guide not saying so is irrelevant.

 

As the Supplement is essentially what was re-written for Retro 9 and it makes no mention of this one way or the other, what specific changes are SUPPOSED TO have occurred and does this REALLY work? Then, does the setting really stick? I still claim the setting issue is a bug. Albeit one that is unlikely to get fixed, judging by the lack of official comment.

 

I claim this simultaneous execution of threads works when enabled and the failure to stick the setting on when selected is a bug.

Share this post


Link to post
Share on other sites

I only tested different sources/different destinations for a copy operation for the test. When my normal backup rolls around, I'll try multiple threads on them. I'd like it to work - it would be more convenient for me, because I run two backups and I have two DVD drives to back up to. It's a bit of a pain, though, that restarting the engine sends it back to single threads, because I normally run with the engine off, so that the rest of the system can access the DVD drives (a problem not fixed since Retro 8 was introduced).

 

Anyway, since the documentation says it's not supposed to work at all, I won't be too unhappy if I can't make it work for my setup.

Share this post


Link to post
Share on other sites

I set ActivityThreads to 8; tried to run two backups (local source and client source to different optical media sets); the backups ran sequentially.

 

But I still think the only bug here is that the Preference panel allows you to set the number of Activity Threads when the documentation says that Desktop can only run a single activity.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×