Jump to content
Don Lee

Time zone handling wrong in email

Recommended Posts

I have 9.0.2 set up to send me email on various events. The emails come in with the right timestamps, but the time ZONE is set one hour off (to the west), so they come in appearing to have been generated an hour later than they actually were.

 

It's no a killer but it should be fixed.

  • Like 1

Share this post


Link to post
Share on other sites

I tested this pretty heavily and my testing showed that this happens when the mail server is configured incorrectly.

 

I used my Macintosh to test with a linux mail server and a gmail mail account. If I used the gmail account the time was correct, if I used the linux mail server the time was off by 1 hour. So the time being displayed is dependent on the mail server being setup correctly.

Share this post


Link to post
Share on other sites

Hi Robin. I'm confused. This is a "raw" email message from the engine. Engine is running Mac OS X 10.6 on an intel Mini. I'm in Minnesota, and daylight savings time. UTC -5 is correct.

 

Return-Path: <retro@c.icompute.com>
Received: from host-213.icompute.com (72.1.155.213) by
mailhost.icompute.com with ESMTP (EIMS X
3.3.9) for <retro@c.icompute.com>; Wed, 23 May 2012 08:28:40 -0500
Date: Tue, 23 May 12 8:28:40 -0600
To: retro@c.icompute.com
From: retro@c.icompute.com
Content-Type: text/plain; charset="UTF-8"
Mime-Version: 1.0
Subject: =?utf-8?B?UmV0cm9zcGVjdCBub3RpZmljYXRpb24gZnJvbSB2aXJ0dWUgKDUvMjMvMjAxMik=?=
Message-ID: <3420624520-568217218@mailhost.icompute.com>
<x-charset UTF-8>Script: ToDisk
Date: 5/23/2012
Script ToDisk: waiting for media
</x-charset>

 

Note that the timestamp inserted by the server is correct - 8:28 AM -0500.

 

The "Date: Tue, 23 May 12 8:28:40 -0600" header in the body of the message looks wrong.

 

I've checked the machine running the engine, and it is also set correctly, as far as I can tell. My mailer is the one flagging this. My mailer is very old, and possibly confused, but the "Date:" header looks like the culprit.

Share this post


Link to post
Share on other sites

All I can tell you is that with one mail server I had correct results and with another mail server the results were wrong. The only change made to Retrospect in my tests was the email account being used. That says to me that one mail server is correct and another mail server was wrong. Retrospect itself just sends the mail, the server converts the time.

Share this post


Link to post
Share on other sites

I checked a couple more machines. The server (mailhost.icompute.com) is set up correctly, and the timestamps being inserted by the server are showing the correct timezone (UTC -0500). It's the "Date:" header, which is part of the body of the message generated by the Retrospect engine that is incorrect.

 

Example of a message from NetBSD: (note server timestamp agrees with "Date:" header)

 

Return-Path: <nospam@mercy.icompute.com>
Received: from mercy.icompute.com (72.1.155.195) by mailhost.icompute.com
with ESMTP (EIMS X 3.3.9) for <nospam@icompute.com>;
Wed, 23 May 2012 11:40:20 -0500
Received: by mercy.icompute.com (Postfix, from userid 1001)
id C4A7977013; Wed, 23 May 2012 11:40:18 -0500 (CDT)
To: nospam@icompute.com
Subject: blah
Message-Id: <20120523164018.C4A7977013@mercy.icompute.com>
Date: Wed, 23 May 2012 11:40:18 -0500 (CDT)
From: nospam@mercy.icompute.com (Donald Lee)
time
11:40 AM

 

Now an example from Retrospect:

 

Return-Path: <retro@c.icompute.com>
Received: from host-213.icompute.com (72.1.155.213) by
mailhost.icompute.com with ESMTP (EIMS X
3.3.9) for <retro@c.icompute.com>; Wed, 23 May 2012 11:41:23 -0500
Date: Tue, 23 May 12 11:41:21 -0600
To: retro@c.icompute.com
From: retro@c.icompute.com
Content-Type: text/plain; charset="UTF-8"
Mime-Version: 1.0
Subject: =?utf-8?B?UmV0cm9zcGVjdCBub3RpZmljYXRpb24gZnJvbSB2aXJ0dWUgKDUvMjMvMjAxMik=?=
Message-ID: <3420636083-568217244@mailhost.icompute.com>
<x-charset UTF-8>This email has been generated by Retrospect to test your settings.
</x-charset>

 

Now an example from a linux system.

 

Return-Path: <nospam@vm1.icompute.com>
Received: from psmtp.com (64.18.1.60) by mailhost.icompute.com with SMTP
(EIMS X 3.3.9) for <nospam@icompute.com>; Wed, 23 May 2012 11:49:50 -0500
Received: from vm1.icompute.com ([72.1.155.214]) by exprod6mx264.postini.com ([64.18.5.10]) with SMTP;
Wed, 23 May 2012 12:49:50 EDT
Received: by vm1.icompute.com (Postfix, from userid 1000)
id C29F362A36; Wed, 23 May 2012 11:49:48 -0500 (CDT)
Date: Wed, 23 May 2012 11:49:48 -0500
To: nospam@icompute.com
Subject: another test
User-Agent: Heirloom mailx 12.2 01/07/07
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Message-Id: <20120523164948.C29F362A36@vm1.icompute.com>
From: nospam@vm1.icompute.com (Donald Lee)
X-pstn-neptune: 0/0/0.00/0
X-pstn-levels:	 (S:43.52964/99.90000 CV:99.9000 FC:95.5390 LC:95.5390 R:95.9108 P:95.9108 M:97.0282 C:98.6951 )
X-pstn-dkim: 0 skipped:not-enabled
X-pstn-settings: 3 (1.0000:1.0000) s cv gt3 gt2 gt1 r p m c
X-pstn-addresses: from <nospam@vm1.icompute.com> [361/14]
11:49 AM CDT

 

Note the Date: header agrees with the linux/postfix-generated timestamp, which agrees with the mail server (mailhost.icompute.com). The Postini mail server says 12:49:50 EDT, but unfortunately, does not have the "UTC -0400" notation.

 

I think the engine doesn't do it right. Sorry to rain on your parade. ;->

Edited by iCompute

Share this post


Link to post
Share on other sites

I checked one more thing: the "date" output on the Mac OS X 10.6 host system where the engine is running:

 

host-213:~ vmadmin$ date -u
Wed May 23 16:59:17 UTC 2012
host-213:~ vmadmin$ date
Wed May 23 11:59:21 CDT 2012
host-213:~ vmadmin$

 

This confirms to me that the OS thinks it is "UTC -5".

 

The "Date:" header is part of the body of the message, and is not correct. How the difference in mail servers made testing come out differently is a mystery to me, but the Date header is still not right.

Share this post


Link to post
Share on other sites

Coming to this late but just upgraded for 8.x to 9.0.2 and saw this problem is still there. It's not new with 9.x as I had it with 8.x.

 

The mail server has nothing to do with the message time. I just did a test by Telnetting to my server's SMTP port and composed a message without a Date: header and the server (Postfix) did not add one. So that Date header is coming from Retrospect.

 

 

Here's the raw source of the last message from Retrospect to me. Note that SpamAssassin has added to the message's Spam Score for the invalid date (in the future).

 

Return-Path: <retrospect@stonejongleux.com>

X-Original-To: larry@stonejongleux.com

Delivered-To: larry@stonejongleux.com

Received: from localhost (localhost [127.0.0.1])

by albion.stonejongleux.com (Postfix) with ESMTP id 8BA984582011

for <larry@stonejongleux.com>; Sat, 2 Jun 2012 19:37:49 -0500 (CDT)

X-Virus-Scanned: amavisd-new at stonejongleux.com

X-Spam-Flag: NO

X-Spam-Score: 1.383

X-Spam-Level: *

X-Spam-Status: No, score=1.383 required=5 tests=[ALL_TRUSTED=-1, BAYES_50=0.8,

INVALID_DATE=1.096, MISSING_MID=0.497, T_RP_MATCHES_RCVD=-0.01]

autolearn=no

Received: from albion.stonejongleux.com ([127.0.0.1])

by localhost (Server-iMac.local [127.0.0.1]) (amavisd-new, port 10024)

with ESMTP id ASveU5+mTX1J for <larry@stonejongleux.com>;

Sat, 2 Jun 2012 19:37:49 -0500 (CDT)

Received: from Server-iMac.local (albion.stonejongleux.com [192.168.1.2])

by albion.stonejongleux.com (Postfix) with SMTP

for <larry@stonejongleux.com>; Sat, 2 Jun 2012 19:37:49 -0500 (CDT)

Date: Fri, 02 Jun 12 19:37:49 -0600

To: larry@stonejongleux.com

From: retrospect@stonejongleux.com

Content-Type: text/plain; charset="UTF-8"

Content-Transfer-Encoding: quoted-printable

Mime-Version: 1.0

Subject: =?utf-8?B?UmV0cm9zcGVjdCBub3RpZmljYXRpb24gZnJvbSBTZXJ2ZXIgaU1hYyAoNi8yLzIwMTIp?=

Message-Id: <20120603003749.8BA984582011@albion.stonejongleux.com>

 

Script: A8 Copy Backup Sets to 2400

Client: dimension2400k

Date: 6/2/2012

Script "A8 Copy Backup Sets to 2400" completed successfully

Share this post


Link to post
Share on other sites

This bug is minor, but very annoying. It's been annoying me since at least Retrospect 8, has it been fixed in Retrospect 10? I guess we won't know until next spring, unless someone down under can test it for us.

Share this post


Link to post
Share on other sites

Add me to the list. Have two Retrospect 9.0.2 (107) servers and both have this bug. It is extremely annoying when away from the office and I'm trying to verify when the backup finished.

 

Any hope of this being fixed?

Share this post


Link to post
Share on other sites

Why wasn't this fixed 2 years ago? I use the email feature to monitor my server. I expect that lots of other admins do this as well. I have several other network devices and services that send me regular emails. This is the only one that has a problem with the timestamp. Messages sent at 9 AM show up as 10 AM in most (but not all) email clients.

 

I can't imagine why this hasn't been fixed. Once the correct piece of code is found, it should only require altering a single character to fix it. 

 

We're considering upgrading to Retrospect 10, but I think we'll hold off until this is fixed.

Share this post


Link to post
Share on other sites

I'm running Retrospect 10.1.1 (221). Microsoft Entourage (2008) is showing the Sent date as 7/30/18 12:00 AM. The date field in the actual email shows "Date: 6/15/13".

 

Something is definitely funky.

Share this post


Link to post
Share on other sites

The emails come in with the right timestamps, but the time ZONE is set one hour off

 

We are testing the fix for the next public release (v10.3).

 

 

Microsoft Entourage (2008) is showing the Sent date as 7/30/18 12:00 AM. The date field in the actual email shows "Date: 6/15/13".

 

We are actively working on this fix, also slated for the next public release (v10.3).

  • Like 1

Share this post


Link to post
Share on other sites

Just FYI, the latest Mac build 10.2.0.207 available through Support doesn't have these fixes, which are in process of being tested and slated for v10.3.

Share this post


Link to post
Share on other sites

Not a time zone problem, but an email timestamp problem anyway.

 

I've recently set up email notification in Retrospect, and most of my emails have a subject line like this:

Subject: Retrospect notification from <servername> (8/31/2013)

and a timestamp like this:

Date: Sat, 31 Aug 13 18:06:33 +1000

Which is what I'd expect (the time zone is also correct).

 

However, emails that Retrospect sends with

Subject: <servername>

and contents

Script: Proactive Backup
Date: 8/31/2013
Proactive Backup started

or

Date: 8/31/2013
+    Retrospect version 10.2.0.201
Launched at 8/31/2013 6:14 PM

or

Script: Proactive Backup
Date: 8/31/2013
Script "Proactive Backup" stopped by operator

or

Script: Proactive Backup
Date: 8/31/2013
Proactive Backup stopped

all have timestamps:

Date: 8/31/13

and show up in Thunderbird as having been sent at 00:00 (midnight), no matter when they were actually sent.

 

I don't know if any other email notifications are similarly affected.

Share this post


Link to post
Share on other sites

the time ZONE is set one hour off

 

Entourage (2008) is showing the Sent date as 7/30/18 12:00 AM. The date field in the actual email shows "Date: 6/15/13".

 

show up in Thunderbird as having been sent at 00:00 (midnight), no matter when they were actually sent.

 

Specifically regarding the standard Date: field in email header and therefore used by various email client software, the 3 issues above are fixed in the next free update.

 

Separately, Retrospect's "Date:" text inside the email body remains unchanged in the next free update. Outside the scope of that free update, we are actively working on improving the overall usability of email notifications.

Share this post


Link to post
Share on other sites

Thanks, Dave.

 

Will the update (beyond the next minor free release) in the email bodies also take account of the date settings in the OS X System Preferences>Language & Text>Region for the dates in the email body? My Region date setting is for d/m/y; the date in the text body is m/y/d.

Share this post


Link to post
Share on other sites

As of Retro 10.5, the time stamp handling appears to be fixed, (at least on Mac OS X on my version of the OS - Mac OS X 10.8.5) 

 

Thank you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×