Jump to content
Sign in to follow this  
Don Lee

Engine crash when operating on "poison" file media set

Recommended Posts

I rebuilt a Retro 6.1 File backup set with Retro 9.0.2.107, and got this in the log:

 

+  Executing Rebuild at 5/13/12 (Activity Thread 1)
   To Backup Set iC_User12 [004]...
   XcaSixOne::ArxExec (2) skipping empty session tree; rootref is zero
   XcaSixOne::ArxExec (1) skipping empty session tree; rootref is zero
   5/14/12 12:16:52 AM: Execution completed successfully
   Completed: 184885 files, 47.5 GB
   Performance: 2,608.1 MB/minute
   Duration: 00:18:39

 

Unfortunately, I deleted the original 6.1 backup set (to save the space).

 

When I try to copy this resultant file media set somewhere, the engine crashes.

 

(It is a little frustrating that the logs for the operations that crash do not appear in the logs at all, nor in the "activity" listing. It appears that these things get updated in the activities list and the log ONLY if the activity completes.)

 

I include 3 assert logs with this post from the 3 incidents where I saw this crash.

assert_log.utx.zip

Share this post


Link to post
Share on other sites

The resultant Retro 9 media set (FILE) remains troubled.

 

I copied off the file that was the result of the retro 6.1 recatalog, so I can reproduce this if required.

 

I then did a rebuild on the v9 media set (FILE). The rebuild yielded this:

 

+  Executing Rebuild at 5/16/12 (Activity Thread 1)
   To Backup Set iC_User12 [004]...
   XcaSixOne::ArxExec (2) skipping empty session tree; rootref is zero
   XcaSixOne::ArxExec (1) skipping empty session tree; rootref is zero
   5/16/12 12:11:00 PM: Execution completed successfully
   Completed: 184885 files, 47.5 GB
   Performance: 3,056 MB/minute
   Duration: 00:15:56 (00:00:01 idle/loading/preparing)

 

I then did a verify on the rebuilt media set.

 

When I do the verify operation, the log looks like this:

 

+  Executing Verify at 5/16/12 (Activity Thread 1)
To Backup Set iC_User12 [004]...
XcaSixOne::ArxExec (1) skipping empty session tree; rootref is zero
5/16/12 12:42:09 PM: Execution completed successfully
Completed: 184885 files, 47.4 GB
Performance: 4,432.1 MB/minute
Duration: 00:10:56

 

I have saved off the 50 GB file in case anyone wants to look at it.

Share this post


Link to post
Share on other sites

I re-ran the verify, and the media set copy again on Retro 10.1. (Retro 10.1.0 (221), Mac OS X 10.8.3)

 

The verify looks like this:

 

+  Executing [u]Verify[/u] at 4/25/13 (Activity Thread 1)
To Backup Set [u]iC_User12 [004][/u]...
XcaSixOne::ArxExec (1) skipping empty session tree; rootref is zero
4/25/13 10:26:40 AM: Execution completed successfully
Completed: 184885 files, 47.4 GB
Performance: 4,902.1 MB/minute
Duration: 00:09:54

 

The media set copy fails, and crashes the engine. The "activity" corresponding to the copy is completely lost. There is no evidence that it ever ran. It is not in the "activities" list, nor anywhere in the log that is displayed with "cmd-L" from the console.

 

The tail of the "cmd-L" log is here:

 

MacProLoc::PGetAbles: Could not connect to share. Mark as offline.
	+	Executing Verify at 4/25/13 (Activity Thread 1)
	To Backup Set iC_User12 [004]...
	XcaSixOne::ArxExec (1) skipping empty session tree; rootref is zero
	4/25/13 10:26:40 AM: Execution completed successfully
	Completed: 184885 files, 47.4 GB
	Performance: 4,902.1 MB/minute
	Duration: 00:09:54
+	Retrospect version 10.1.0.221
Launched at 4/25/13 10:50:19 AM

 

I saved the 56 GB media set (file) if anyone wants access to it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×