Jump to content
Sign in to follow this  
Don Lee

Race condition on v6.1 tape rebuild and tape loading - steps to reproduce bug

Recommended Posts

This has been a real frustration to me. I now know how to work around it, and describe how to reproduce it.

 

I have tracked down the trigger for a problem where I rebuild my v6.1 tapes, and Retrospect 9 happily reads the entire tape set, but comes out with a catalog showing zero files. I have documented several similar cases of this here.

 

I have not tried to explore all the combinations of conditions on this, just the ones that were relevant to me. My tape drive is a USB HP DAT72 tape drive (Storage Works). Retro 9.0.2.107, Mac OS X 10.6

 

One procedure for reproducing this bug is as follows:

 

1. Ensure that the tape you want to rebuild does not have a v9 catalog. Tape drive should be empty.

 

2. Go to the "Media Sets" display, and click on "rebuild". The first dialog selects the type of rebuild. Choose "tape". Click "next".

 

3. Next dialog selects the device. Choose the (empty) tape drive. Click "next..."

 

4. Next dialog chooses the location of the catalog. Wait here. Timing is important. Select your catalog location, but DON'T click "rebuild".

 

5. Insert the tape in the drive.

 

6. Immediately hit "rebuild" in the dialog. You will get an error. Keep clicking "rebuild" until the dialog is dismissed.

 

Watch the activity, and watch Retro read the tape, without effect - note in the summary window in the activity that no files are counted, and no MB/s rate is displayed. It will read the entire tape, and do nothing.

 

On the other hand, If you wait until Retro has recognized the tape before you click "rebuild", it will work fine.

 

I smell a race, and user frustration for the impatient. (like me. ;->)

Share this post


Link to post
Share on other sites

I confirmed my theory today. I went back to a media set (backup set - 6.1) that I had tried to rebuild several times, and given up. When I waited for the tape to fully load, and come up with a name, the rebuild worked fine.

 

Race.....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×