Jump to content
597ab11f-9df4-4e86-9fdb-8cf539342610

Retrospect Can't See It's Own Rdb File?

Recommended Posts

I was having problems w/ my backup set (ran out of room on my NAS, which I think caused a problem, so then upgraded NAS space). Running the most current version of 7.7.

 

I created a new data set on my NAS and tried to back up my full hard drive to it from my main PC which runs retrospect - about 220gigs. The backup runs fine, but then in verification, chugs along then reports a member file missing .. I can see the file clearly there in explorer when I look at all the backup files, but when I try to use the dialogue box that retrospect presents, it can not see any files in that directory .. like none are there! When I pull down the drop down to let the dialoge box show all files in that directory, the other choices for file types are gibberish. I know the exact file retrospect wants next to verify is there on the file system, I don't know why retrospect can't see it.

 

I have tried this full backup twice, and each time the same thing happens, but with a different rdb file (00047 in one case and 000258 in the second). My NAS parity checking is all good, so I don't think it's a NAS file system problem.

 

I select the file as "missing" at which point retrospect cancels the backup. All files are there but it won't complete the verification. I then go in and uncheck the "this member is damaged" because I don't believe it is - I think the file verification has a problem.

 

However, I just tried to backup to the same set again just now, thinking it might try to deal with the files in the "missing" rdb file, but retrospect goes to back up *all* files again - as if all of my files are not in that backup set, eventhough most or all of them are and I have file name matching set so that duplicate files are not backed up again.

 

All of my other backup sets, which are backups of docs and settings from my other PCs, are working fine - no problems at all.

 

===> 1. Has anyone had the above happen and found a work around to the fact that retrospect doesn't seem to see the rdb file it just created?

===> 2. Does anyone have a strategy for creating and maintaining a backup of a full hard drive that will allow the process to complete successfully and perform incremental backups? I feel that if I could just get this one initial backup to work successfully, the incremental backups and grooming should be ok since my others are fine.

 

THANK YOU!!!!!!!!!!!!!!!!!!!

Edited by daves2
  • Like 1

Share this post


Link to post
Share on other sites

1. It doesn't happen here. We use iSCSI, so the Retrospect server sees the NAS disk as a local volume.

2. We do as you do and it works here.

 

Sorry I can't be of more help.

Perhaps if you tell us which NAS it is and how the volume is mounted, then someone might have a clue.

Share this post


Link to post
Share on other sites

thanks although I am not suspecting the NAS, as all other backup sets on the NAS work fine even now after I upgraded the storage. NAS is a Synology DS410 mounted as a mapped network drive, which I have been doing for months and no problems. but again I believe it seems more like a retrospect error of some type with the application (the oddity in the drop down box where the other choices, that are usually something like .exe, all files, etc. is more like garbled non-letter characters).

 

thanks for your reply..!

Share this post


Link to post
Share on other sites

well, here's my own update .. I tried this for a third time and it worked - all 285,000 files on 210gig - 17 hours to backup and verify. the only 2 things that were different this time were (1) I ran a norton ghost 15 image of the hard drive since I was having troubles in retrospect (should have had no impact on retrospect) and (2) for this backup set (I created a new one each time), I specified the catalog file to reside on the NAS instead of the hard drive itself.

 

My guess would be that it was (2), moving the catalog to the NAS, which fixed it - not sure why - either corrupted file space on the hard drive where the catalog file was being built each time or something else similar, can't really explain it. But, I really should have had that catalog file on the NAS, for DR purposes. (since this hard drive is the main system that runs retrospect).

Edited by daves2

Share this post


Link to post
Share on other sites

i wanted to mention that i also just experienced this with retrospect 7.7 multi-server, and found a solution (better late than never).

(solution at the bottom)



===How it started===

i made a copy of my backup files (data and catalogs) at my system dedicated to running backups. this was a simple copy from one external usb drive to another (to store off site) and not through retrospect. after this copying, i connected this drive to a different system running a clean install of retrospect. on this system i wanted to add each backup set to verify them. so i did this:


Configure > Backup Sets > More > Open > selected a catalog

and then changed the drive letter of the "location" to the usb drive's letter (because it's different from my backup system)

Configure > Backup Sets > Properties (of added backup set) > Members > Properties (of the member's folder)

but retrospect didn't allow me to click ok (it gave the message "this folder can't be used...") but the ok button worked after i used the "Browse" button to select the same location (very strange).


ran verification:

Tools > Verify Media > clicked the (added) backup set > OK

***this is where the problem occurred***
the verification just started but it imediately asked me to select the location of the member, even though it was already set as mentioned above. giving it the location through the "choices" button only makes it run for a moment and ask for the next file (strangely, the open file dialog contains strange symbols as file types)



===How i solved it===

- Configure > Backup Sets > Properties... (of the backup set) > Members > Properties (of the member)

- now CHECK "This member is lost or damaged"

- click OK to close this dialog

- Properties (of the member) again (to open the dialog you just closed)

- now UNCHECK "This member is lost or damaged"

- click OK to close this dialog again

- now also close the backup set's Properties dialog (the one with the "members" tab)

done



(media should work now without asking for every single *.rdb file)

this has worked everytime for me (restarting/reinstalling retrospect didn't help). the solution doesn't make much sense, so i consider this a bug.

Share this post


Link to post
Share on other sites

I had this issue today, yet even when I check 'member is lost/damaged' it wouldn't let me click OK! I'm resigned to the fact, since upgrading to 8.2 the other day, I need to rebuild my config file *yet again* to get things working.

 

If I still have problems, I'm dropping Retrospect.

 

Richard

Share this post


Link to post
Share on other sites

I had this issue today, yet even when I check 'member is lost/damaged' it wouldn't let me click OK! I'm resigned to the fact, since upgrading to 8.2 the other day, I need to rebuild my config file *yet again* to get things working.

 

If I still have problems, I'm dropping Retrospect.

 

Richard

hi Richard,

 

just to be sure. i talked about 2 problems:

 

 

1. to be able to change the location in the member properties dialog at

Configure > Backup Sets > Properties... > Members > Properties

and be able to click "OK", i suggested:

- using the "Browse" button and then clicking "OK" (instead of typing the location and clicking "OK")

 

 

after that i've always tried to run the verification again.

 

 

2. to stop it from asking the location of each *.rdb file during the verification, i suggested:

- go back to Configure > Backup Sets > Properties... > Members

- open the Properties (of the member) dialog

- CHECK the "This member is lost or damaged" checkbox

- close it with "OK" but leave the Backup Set's Properties dialog (the one showing Members tab) open

- open the Properties (of the member) dialog again

- UNCKECK the "This member is lost or damaged" checkox

- close it with "OK" and now also close the Backup Set's Properties dialog (the one showing Members tab)

 

and try the verification again.

 

 

i've never tried to change the location and do the checking and unchecking in the same step as you seem to be suggesting.

Share this post


Link to post
Share on other sites

Ah right, maybe a different issue then. For some reason, my RS server complains it can't find the backup set *very* occasionally and no matter what I do it won't accept the location I browse to. Yet (!) I can still look at snapshots and even copy data from it to a new backup set - very weird.

 

Anyway, still rebuilding my server 8 hours later as RS kept crashing when I exported the Selectors, so some corrupted and I'm having to rebuild the most complicated ones by hand (which is painful after several years of maturing).

 

Ah well... it does seem a *little* better at repairing the catalogs now :) I'll see how 8.2 goes when battered tomorrow.

 

Rich 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×