Jump to content
robertdimmick.me.uk

Assertion Failure At Tstring.cpp2214

Recommended Posts

See http://forums.dantz.com/showtopic.php?tid/31752/ for earlier posting.

I was running Retrospect Express HD 2.5 on Windows 7, and have done for about 18 months.

RE was rebuilding its index, as it rather often has to do, and this hung. An attempt to backup also hung.

On restart, it displayed the message "Assertion failure at tstring.cpp2214"

 

Looking at the posting referenced above, I renamed J:\Retrospect Restore Points\RestorePoint3.rbc (see Post#131323) and C:\ProgramData\RetroExp\operations_log.utx (see Post#128671) but this had no effect.

 

According to Roxio people on the posting, this should be cured by version 2.5.126 which should have been available within "a week or two" (128671) from 28 September 2009. But the version in the website is STILL 2.5.113 on 3 April 2011.

 

I have not yet tried the more radical solution at http://forums.dantz.com/showpost.php?post/128088/ because I didn't want to lose my backups. Looks like I will have to. This solution is:

"Eventually I fixed it by uninstalling the program, cleaning the registry (used CCleaner, probably unnecessary, but I wanted everything out) and, most importantly, deleting the configuration file which uninstalling leaves behind. This is normally located in Documents and Settings\All Users\Application Data\RetroExp. Simply delete the whole folder. I found it was also necessary to delete (or rename) the previous Retrospect Restore Points folder on the external backup drive (see below).

 

After a clean reinstall it is now working perfectly, admittedly at a cost of losing all my previous backups."

Share this post


Link to post
Share on other sites

Continuing from previous post by myself...

 

I renamed the RetroExp folder and rebooted.

 

Retrospect Express HD started and asked for my licence key. It then displayed the message "Backup maintenance in progress... this may take a while".

 

It took just over six hours to recover 51 restore points (640Gb). After that it showed the screen "Welcome to Retrospect Express HD", and I selected "Setup" and set it up to daily full backups (as before). A backup was started.

 

After over 8 hours (overnight) the screen still showed:

"Backup in progress, OS (C:)

Preparing... this may take a while".

The external disk and the internal hard disk sounded/looked as if the program was looping, doing the same thing at intervals of about one second.

 

I clicked "Stop this backup".

 

After a few minutes, an icon appeared on the taskbar which when clicked offered to show me a message. The message read:

"Retrospect has encountered a serious error.

Assertion failure at “tstring.cpp-2214”

A log of this error has been written to the file “assert_log.utx”.

Please tell EMC about this problem.

We have created an error report … "(remainder of message not written down).

 

I sent the message, then tried to close Retrospect Express from the taskbar icon without success. I closed it using Task Manager.

 

I tried to attach assert_log.utx to this posting but got the error "You aren't permitted to upload this kind of file." I therefore renamed it as a .txt file and attached it.

 

 

I now intend to attempt a total backup using Windows Backup. If this succeeds I shall uninstall Retrospect Express and delete all its backups.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×