Jump to content
Sign in to follow this  
lafong

Solved our -1020 and -1017 errors

Recommended Posts

We've had several users getting -1020 and -1017 errors in the last few months. Finally found the full solution to our problems. This may not solve everyone else's -1017/1020's, as always YMMV. Our problems came about because the uninstall routine for Visio caused VSS and COM+ issues. Getting errors when using the vssadmin commands below would be a good indicator as to whether your issue was the same or similar.

 

 

 

At each problem PC:

 

Registry: (The usual be-careful-make-backups-before-editing-the-registry advice applies.)

 

1) Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ContentIndex\Catalogs in regedit.

 

 

 

2) Look through the keys in this folder. Usually, there will be a System and maybe a Web key there, which should not be touched.

 

 

 

3) Delete any keys which refer to apps/paths that no longer exist. In our case, it was the "Visio" key. The users had uninstalled Visio, but the key remained. Be sure, first, that Visio is no longer installed of course.

 

 

 

4) Refer to Microsoft Article ID 907574 for full details.

 

 

 

COM+ and VSS DLL's Re-register:

 

1) cd %WINDIR%\System32 (swprv will not re-register if you are not in this directory)

 

 

 

2) Run these commands:

 

net stop vss

 

net stop swprv

 

regsvr32 ole32.dll

 

regsvr32 oleaut32.dll

 

vssvc /Register

 

regsvr32 /i swprv.dll

 

regsvr32 /i eventcls.dll

 

 

 

I have not used the /s option above, so all of the regsvr32 commands should produce a "succeeded" dialog. It may take several seconds for the swprv.dll success dialog to appear.

 

 

 

3) These VSS commands should now not have any errors:

 

vssadmin list writers

 

vssadmin list providers

 

vssadmin list shadows (There may be no shadows, but there should be no errors).

 

 

 

4) Reboot the PC

 

 

 

5) They should no longer get VSS errors in Event Viewer\Application during Retrospect backups.

Share this post


Link to post
Share on other sites

Thanks for this information. I have the issue of the 1017 error and many 1020 errors as well so I tried your suggestions. I did not have any keys that referred to apps/paths that no longer exist. During the 2nd part I received an error message:

 

DLLINSTALL in swprv.dll failed - returned 0x8000ffff.

 

All other statements were successful.

 

Would you know why I would receive this error?

 

I have set VSS to run automatically.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×