Jump to content
Sign in to follow this  
pronto

[Solaris] Error 1101 (File or Directory not found)

Recommended Posts

Hi Community,

 

after an upgrade our Retrospect Version 6.5 to 7.0.x, the backup of a solaris 8 machine failed with 60 Errors -1101 and more than 1.500 Warnings -1101 (File or Directory not found). It seems to me, that in any affected file are german Umlaute (äüö) involved, but in other volumes on the same machine, are files with german umlaute too and they will be backuped without any problems. Thre is only one volume affected by this problem.

 

Before the update has been carried out, the backup was working well, without any errors or warnings.

 

Can anybody help to fix this problem?

 

Bye Pronto

Share this post


Link to post
Share on other sites

Hi

 

What is the default encoding set to on this machine? You may want to go back to the 6.5 client to see if that works any better.

 

Thanks

Nate

Share this post


Link to post
Share on other sites

Hi,

 

sorry for my being late ;-)

 

The default encoding set on the solaris machine is: LC_*=en_US.ISO8859-1; but before we udgraded retrospect there are no problems with this encoding set. A downgrade to the client version 6.5 we had already done, respectively we tested it before we upgrade the client with the same result. First we thought that the outdated version of the client is responsible for this error, but the following upgrade didn't solve the problem.

 

Bye Tom

Share this post


Link to post
Share on other sites

Hi

 

Retrospect 7 was the first version to make adjustments for encodings on Unix/Linux client machines. Retrospect is looking at your filesystem with English only encoding but there are some unicode characters in the German file names. I believe you can set a different encoding in the Retrospect client files somewhere but I don't know where.

 

I'll try to sort this out and come back to you.

 

Nate

Share this post


Link to post
Share on other sites

Hi

 

Sorry for the delay. Here is the scoop:

 

You can either change the encoding of the system to match the German files or you can try to change the encoding that Retrospect will use. To do the latter, modify the rcl script and add "export LANG=(whatever encoding the German files use)" before retroclient -daemon is called.

 

Hope that helps,

 

Nate

Share this post


Link to post
Share on other sites

Hi natew,

 

Thanks for your reply.

 

How does affect this workaround (to modify the rcl script) the backup of the other volumes which are not encoded with an UTF-8 charset? Thre are many volumes on this server and only one is UTF-8 encoded. I think to define in the rcl script the charset en_US.ISO8859-1 is not the proper way, because this charset is already defined in solaris and i think retrospect take notice about the system settings. So i have to experience with a different charset (e.g. de_DE.UTF-8) wich is unknowned by the operatingsystem. So i fear that maybe the backup of the other volumes failed, cause the defined charset in retrospect does not match with the charset in what the other volumes are encoded. Or is there a possibility to define more than one charset in the rcl script?

 

Anyway, how does the retrospect client works with a defined charset which is unknowned by the operatingsystem?

 

Thanks for your attention

 

Bye Tom

Share this post


Link to post
Share on other sites

Hi

 

You can only select one encoding type. Assuming your other disks only contain single byte characters the encoding change shouldn't make much difference.

 

Thanks

Nate

Share this post


Link to post
Share on other sites

Hi all,

 

i got an updated rcl file from the Dantz Support which contains an export command:

 

'export LANG=C'

 

Momentary i don't know what 'LANG=C' effect but maybe this will fix the problem, i will report how it works.

 

Bye Tom

Share this post


Link to post
Share on other sites

Hi all,

 

this workaround doesn't work. I believe that the problem isn't a client probleme because the client version 6.5.x doesn't work too. My guess is, that there is a probleme in the server component or in the communication between client and server. We are waiting now for a statement from the dantz support.

 

Thanks for your attention

 

Bye Tom

Share this post


Link to post
Share on other sites

Hello,

what happened with this issue? Im interested because I have a similar problem with swedish characters. Use Retrospects 7.5 running on winXP backing up a Solaris-box storing files for Macintosh-workstations and the solaris running apple-talk. Yes, I´m confused too…

 

/Christer

Share this post


Link to post
Share on other sites

Can you try adding the line 'export LANG=C' without the quotes to /usr/local/dantz/client/rcl? It should be added before the line that says CLIENTDIR=/usr/local/dantz/client. Be sure to restart your client after you make the changes.

Share this post


Link to post
Share on other sites

Thank you. I have changed and restarted the client now, but retrospect is busy backing up other things, so I can´t verify it yet. I´ll be back.

 

/Christer

Share this post


Link to post
Share on other sites

hi deld,

 

so you are still having problems even though you specified the 'export LANG=C'? i've seen this work before, and i've also heard of someone using just, 'LANG=C', without the export. i'd imagine you could also use the form:

'LANG=C

export LANG'

 

what this does is specifies the character set of the system. i believe 'LANG=C' means unicode.

 

do you know what specific character set you are using on this Solaris computer? if you could post it, i'm sure it would help.

Share this post


Link to post
Share on other sites

Hi,

 

To find out what character set you are using type locale at the command line and go ahead and post all of what comes up.

 

Thanks

Share this post


Link to post
Share on other sites

Hello again,

Thanks for all the help so far. This is the output of locale:

 

# locale

LANG=

LC_CTYPE="C"

LC_NUMERIC="C"

LC_TIME="C"

LC_COLLATE="C"

LC_MONETARY="C"

LC_MESSAGES="C"

LC_ALL=

#

 

Looks like "C" is the key here. What does it mean? And is this correct in sweden?

 

/c

Share this post


Link to post
Share on other sites

Hi,

 

C is the standard value and is usually default. Could you try and post some of the names of the files that are having the problem(not sure if they will show up correctly but try anyways) and what version of the client do you have installed and what version of solaris?

 

Thanks

Share this post


Link to post
Share on other sites

Hi,

 

Sorry for the double post but how are you creating the files? Are you creating them locally or from a another machine using a third party software?

 

Thanks

Share this post


Link to post
Share on other sites

I'll mention that I had this same problem on my Linux box (running client 7.5.112) when Retrospect 7.5 was trying to backup a folder that contained many l10b files (with l10n file names).

 

I added:

 

export LANG=C

 

to my /etc/init.d/rcl file [which is where my file lives] and the client now backs up all the files it previously errored out with. I even restored some of the problem files and they restored OK so this solution worked for me (where the default LANG on my system was "en_US.UTF-8")

Share this post


Link to post
Share on other sites

thanks for posting that tait, and i'm glad this worked out for you.

 

just as an addendum for future readers of this thread: it's my understanding that the Linux and Solaris Retrospect Clients have the same codebase. if you are having this problem on either platform, try the suggested resolutions, but if they do not work make a call in to EMC Insignia Technical Support.

 

cheers.

Share this post


Link to post
Share on other sites

Here is a slightly modified rcl file we use that includes the LANG=C and a "restart" parameter:

#!/bin/sh
# Retrospect Client rcl script 
# 
# Contact Information 
# 
# EMC Dantz
# 3003 Oak Road, 3rd Floor 
# Walnut Creek, CA 94597
# 800.225.4880 or 925.948.9000
# customer_service@dantz.com
# 
# Copyright 2000-2004 EMC Dantz
#
# 
# Place this script along with retroclient, and 
# retrocpl in the directory specified by CLIENTDIR.

### BEGIN INIT INFO
# Provides: retroclient
# Required-Start: $local_fs $syslog
# Should-Start:
# Required-Stop:
# Default-Start: 3 4 5
# Default-Stop: 0 1 2 6
# Short-Description: Retrospect Client
# Description: Retrospect Client
### END INIT INFO
export LANG=C
CLIENTDIR=/usr/local/dantz/client
case $1 in
   start)
   echo Starting...
   $CLIENTDIR/retroclient -daemon
   ;;
   stop)
   echo Stopping...
   $CLIENTDIR/retrocpl -stop
   ;;
   restart)
   echo Stopping...
   $CLIENTDIR/retrocpl -stop
   echo Starting...
   $CLIENTDIR/retroclient -daemon
   ;;
   status)
   $CLIENTDIR/retrocpl
   ;;
   *)
   echo "Usage: $0 {start|stop|status|restart}"
   ;;
esac
exit 0

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×