Jump to content
Sign in to follow this  
jfucci

Error 1017 - Insufficient Permission

Recommended Posts

I have Retrospect Professional 6.5 installed on a Windows XP Home Edition (SP2) PC and am trying to backup some network shares and I keep running into the 1017 - Insufficient permission error. The network shares are actually on NAS devices rather than another Windows PC. One NAS device is the Buffalo Technology HD120LAN and the other is the Linksys NSLU2. I have 2 shares defined on the Buffalo device and 3 shares defined on the Linksys device. All shares are mapped to the Windows PC and I have access to them with no problems through Windows.

 

I have set up 2 scripts within Retrospect, one to backup the Buffalo shares, and one to backup the Linksys shares. Both scripts always fail with a 1017 - Insufficient permissions error. But it always backs up one of the shares per script. And it is always the same share for each script. When the scripts were first created, a user ID and password were entered for each share so that Retrospect should be able to login and access the data. And it seems to be able to do that with one share per script. However, after the backup is done, if I go back and edit the script, the password is missing for the shares that weren't backed up. I can re-enter the password and execute the backup immediately, and it works just fine, backing up all the shares. But the next time it executes according to the schedule, it fails again with the 1017 error.. And again, going back into the script, the password is missing for the shares that failed.

 

Has anyone run into this problem, or have some insight into it?

 

Thanks!

 

John Fucci

Share this post


Link to post
Share on other sites

Hi

 

Make sure to set the Retrospect security preferences to run as the administrator of the machine running Retrospect.

 

Thanks

Nate

Share this post


Link to post
Share on other sites

Hi

 

Actually there are a number of system level accounts that Retrospect will use. It will only run as administrator if you tell it to.

 

To clarify: You have added the administrator account and password to the security preferences in Retrospect?

 

The "run as logged on user" setting will cause the error 1017.

 

Thanks

Nate

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×