Jump to content
Sign in to follow this  
FuzzyJohn

Error -1101 When Backing Up to a Network Volume (scheduled)

Recommended Posts

Windows 2000 Professional SP-4

Retrospect Professional 6.5 with the latest RDU

Backing Up to my Novell Network volume

 

Immediate backups to this volume take place without any problems. However when I tried to schedule a backup to the network volume, the backup failed with the message "Error -1101 (file or folder not found)". Scheduled backups to a local volume ran without any problems.

 

After searching the Knowledgebase I found Article # 5660 - TITLE: What causes error -1101 (file or folder not found) on an unattended backup of a Microsoft networking volume?

 

As instructed I changed the Retrospect Launcher service to use my network login credentials (Administrator level) instead of the Local System account.

 

However after this change the scheduled backups did not run at all at the scheduled time. They only ran after manually launching Retrospect. After turning off the scheduled backups in Retrospect Preferences and then turning them back on the schedules ran again but the Retrospect Launcher Service was reset to using the Local System account instead of my account. Once again I changed the login credentials to my own and once again the schedules did not run.

 

How do I get out of this loop???

Share this post


Link to post
Share on other sites

Quote:

Windows 2000 Professional SP-4

Retrospect Professional 6.5 with the latest RDU

 

As instructed I changed the Retrospect Launcher service to use my network login credentials (Administrator level) instead of the Local System account.

 

 


 

Changing the the service login (from LocalSystem to an ID with network permissions) only applied to Retro 6.0 (?) and before. With 6.5, leave the service LocalSystem alone (change it back on your case) and look under the Preferences tab *within* Retro. You'll find a panel (Security I think) that will let you change the login to your network ID (and password and domain or local machine name). See what happens with your other problem after you change these settings.

Share this post


Link to post
Share on other sites

Hi GoAWest,

 

I tried supplying the login info on the Security panel. No matter what I tried to put in the "Log on to" box I kept getting the message "Can't grant necessary user privileges."

 

The only thing I could do was to save the schedule as a Run Document and then rely on the Windows 2000 Task Scheduler to run that Run Document as my Username and my password. However that leaves Retrospect running after the backup is done and if the backup ran at a time when no user was logged in, after I login Retrospect is still running as shown by the Task Manager but I cannot see its window on the screen. If I try to run Retrospect I get a message that the program is currently being run by another user. Clicking OK in that dialog will end the Retrospect instance that was staretd by the scheduler and then will start it again under my login.

Share this post


Link to post
Share on other sites

So you're doing (under Preferences->Execution->Security, not the Retrospect Launcher Service):

 

User:.......... UserName

Password:... UserPassword

Log on to:....DomainName if domain

.................. MyMachineName if workgroup

 

I assume you're logged in from an admin-level account that has a password when you're running Retrospect and setting this up and the above UserName account is also an admin-level account with a password (probably the same).

 

When you "Run Document" you're causing Retro to run under the currently logged-in account, so it's getting your username/password privledges.

Share this post


Link to post
Share on other sites

Maybe I am confused, but when I look at Preferences | Execution | Security it looks to me like the username/password/domain I supply there will be used to access volumes to backup from, not to backup to. Anyway my Novell login is to the NDS Tree and whatever I put in the "Log on to" box is just not accepted.

 

When I "Run Document" by a task in the Windows Task Scheduler, I supply my username/password to the task. At that point the task will run even if no one is logged in or if another user is logged in at the time. This would be acceptable except that Retrospect when started by the Windows Task Scheduler will not close when the backup is done and it will just linger in the background.

 

For now though probably the easiest way to do it is to use Retrospect 6 to backup to the network volume and give the Retrospect Launcher the username/password info. That, and try to keep up with the periodic mandated password changes. cool.gif

Share this post


Link to post
Share on other sites

It's not so much a "from" or "to" thing (or really, it's both). Retrospect is using Preferences | Execution | Security "Run Retro as specified user" to log into your PC as a user, domain or workgroup, with the needed permissions (read, write, etc.) to access the local machine resources *and* the network volumes (writing *to* in your case). Assuming you use the same name/pw/domain when you log in as you set in Retrospect, Retrospect should be able to do the same things as you.

 

In the case of a Windows Domain, the domain controller grants Retrospect privileges (really should be admin-level) to the local machine *and* privileges to access the network volume using the "Run Retro as specified user" info.

 

In the case of a Windows Workgroup, there is no common authority (i.e. no domain controller), so you usually need to have an *identical* login (name & password, with your local machine name specified in the "Run Retro as specified user" setting) on the machine at each end unless you share the network volume as wide open r/w.

 

I guess I'm confused too. Who/what is complaining about not logging in? Is it Retrospect or Novell? Retrospect is using the "Run Retro as specified user" to log into your machine and the Windows network but probably not using it for any Novell login. Is your login for your local machine different or does it use a different login mechanism (e.g. one you're doing manually, which is why the "Run Doc" method works) than for logging into the network (e.g. via a Novell login)?

 

----------------------------------

On this issue of Retro not quitting if you use the "Run Doc" and Windows Task Scheduler, have you tried changing the setting of "Stay in Retrospect" to "Quit" in the drop down at the top of Retrospect? I haven't tried this and don't know if the setting is "sticky", but you're right that you can't do it from the Prefs (since that only applies to auto-launched Retro.

Share this post


Link to post
Share on other sites

Anytime I enter login info in Preferences | Execution | Security the message box that comes up saying that no privileges can be granted is a Retrospect message box.

 

My Windows and Novel username and passwords are synchronized (the same), with Admin level for Windows. I only have to do one login into Novel. That logs me into Windows as well.

 

As for changing "Stay in Retrospect" to "Quit" that seems to make Retrospect quit as soon as I make the change but next time I restart the program it is back to "Stay in Retrospect". Doesn't stick too well... not enought time for the glue to dry.

Share this post


Link to post
Share on other sites

Hi

 

 

 

my apologies if this is redundant...

 

 

 

The login in the Retrospect security preferences should be for an administrator account on the local machine running Retrospect. _not_ the login of a network share.

 

 

 

You can configure logins for individual network shares from the configure->volumes window in Retrospect.

 

 

 

There is a reason for all this silliness of course.

 

As a security precaution Windows does not allow the system account to access network resources. If Retrospect launches itself using the system account Retrospect will also lose the ability to access network resources. By giving Retrospect a user account to launch as, Retrospect will be able to log into network shares like a normal user does. At that point Retrospect can use the login information listed in configure volumes to log into network shares.

 

 

 

Clear as mud right?

 

 

 

Nate

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×