Jump to content

Search the Community

Showing results for tags 'ampersand'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Announcements, News and Resources
    • Latest News
  • Windows Products-Retrospect
    • Professional
    • Server, SBS and Multi Server
    • Device and Hardware Compatibility-Windows
    • Exchange Server Add-On Support
    • SQL Server Agent
    • Linux, Unix and Netware Clients
    • Express for Windows
    • Product Suggestions-Windows
  • Mac OS X Products-Retrospect
    • Retrospect 9 or higher for Macintosh
    • Retrospect 8 For Macintosh
    • Retrospect 6: Desktop, Workgroup and Server for Mac OS X
    • Device and Hardware Compatibility-Mac OS X
    • Linux Clients
    • Product Suggestions-Mac OS X
  • Macintosh OS 9 and Earlier-Retrospect
    • Express, Desktop, Workgroup and Server for Pre-OS X
    • Device and Hardware Compatibility Pre OS X
  • General Discussion-Retrospect
    • Networking and Clients
    • Strategy, Scripts and General Use
    • Retrospect iPhone App
  • Retrospect 8.x for Mac
  • Retrospect 6.1 for Mac
  • Retrospect 7.7 for Windows
  • Retrospect 7.6 for Windows
  • Retrospect Express
  • General Discussion

Categories

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. Retrospect seems to have a bug on Windows with its handling file names and path/folder names containing ampersand characters. The bug is shown in the two annotated screenshots attached to this post. When specifying a single ampersand '&' character in a file/path name, the ampersand is omitted and an underscore is shown in the following character. When doubling the ampersands && the problem seems to go away but the selector is then internally incorrect. I verified this with at least one selector, where despite it looking incorrect with the underscore (caused by the single ampersand), it worked fine in finding the path containing the single ampersand, but when doubling the ampersands && (which escapes them for the UI components), while the UI looked correct, the selector was then incorrect with a double ampersand. Some classic Windows UI elements use ampersand as a way of indicating accelerator characters for UI fields and controls. For example, to specify "&First name" while creating UI resources leads to the F appearing underlined in the UI to indicate to the user it is the accelerator character. My guess is that Retrospect isn't filtering or dealing with this, and just displaying raw user entry into Windows components that are interpreting characters to be accelerators. Note, I notice this problem also affects files already backed up which contain paths with ampersands... if I go to the backup sets and view snapshots or sessions for such a file, and choose Properties, the UI will show paths which actually contained a single ampersand by omitting the ampersand itself and underlining the following character... my guess is that the UI is incorrect but that the underlying backup and name of the path is correct. For example, a backed up file with a path "C:\This & That" will show up in the UI properties for the file as "C:\This _That" because the UI control is seeing a single non-escaped ampersand so it then uses that to underline the next character which is the space before "That" so you get "C:\This _That" in the UI which is very confusing. Thankfully this appears to be a UI issue only but it's incredibly painful when one is trying to solve integrity problems elsewhere and examining things so an eventual fix would be nice. It seems as though some filtering/escaping is required to fix this. Thanks so much for listening!
×