Jump to content

swalker

Members
  • Content count

    56
  • Joined

  • Last visited

  • Days Won

    1

swalker last won the day on June 16 2013

swalker had the most liked content!

Community Reputation

5 Neutral

About swalker

  • Rank
    Occasional forum poster
  1. I often have to delete and re-add clients at the server (without touching anything on the client) to get them to work again.
  2. I am using 10.5 on OS X 10.6.8 and most of my proactive clients are getting ignored in one script, yet working in another (which backs up very big files separately).
  3. I have previous approval to buy a new Mac Pro when they come out, but it looks like the main IO will have to go through Thunderbolt. I currently use a LTO tape drive via PCI SCSI card. What options am I likely to face in the fall for connecting? Looks like a new tape drive might also be in order to keep things simple. Trying to plan ahead a bit.
  4. Extract from Retrospect 9.0 Read Me gives me some hope: ... Over 250 bug fixes, including improvements to the media request process, >> a config file backup process that provides better protection against corruption << , and the elimination of certain spurious errors... Anything more we should know about this?? Yes, I am a geek and am curious.
  5. Disappointing. I really just wanted the product to work. For me, new features are just new things that can break. Adding the kitchen sink to a product is not the way to make it reliable. Certainly not how I design stuff. Any word from the developers when they might make this aspect more bullet-proof, or are they just running scared with marketing? I mean I wish them well, as it appears that maybe the product has been rescued from a series of inappropriate relationships by people who care, but my relationship with the product is still compromised.
  6. One of the developers stated in this forum last year that separating logs and settings was planned for an significant upgrade in the not-too-distant future. Would like to quote it, but it seems to be lost and the Internet wayback machine seems not to have a copy. This is the only "feature" I am really looking for.
  7. The biggest grief I had with 8.x was the corruption of the settings file, where sources or scripts or other vital details would spontaneously go missing. Will the product work if I lock this file? Is it now stored separately from logs, etc?
  8. I have one client that is very slow and has been for years, including under several versions of Retrospect 6 and Retrospect 8, and many versions of Mac OS on a couple of Retrospect servers. The client hardware has also changed over the years. The user doesn't do a lot with his computer. All that seems to be common over the years is: He is Japanese, not a power user by any means. His client is Windows (all other Windows clients are fine). The place everything bogs down appears to be "Building Snapshot..." as reported by the Status line in the Summary pane while the backup is proceeding. The backups are fine but take many hours to complete for relatively few changed files. I am curious if there is a solution.
  9. swalker

    Backup scripts randomly change

    I had this problem for a while, then things settled down, cause unknown, but the five scripts I run don't have enough in common to be cloned from each other. Suggestions? You could try the hearsay that I posted at the end of the "Engine Crashing...again" thread.
  10. swalker

    Engine Crashing...again

    A suggestion from my experience: Retrospect Has been stable for me in the last 2 months, after a period in which I had to keep fixing things regularly due to config corruption and the engine crashing. It crashed last night. Normally I run the console to check on things and then quit it, but this time I left it open. Maybe it it a good habit to quit the console promptly after use to improve stability. The other habit I have gotten into is to give the console a few extra minutes after connecting before I use it to make sure it has all the config info from the server before I modify things. I also do a quick check on the scripts, sources and destinations before modifying anything. Once in a while the config seems to load incorrectly, then I quit the console, then launch it again after waiting a few minutes. For example, this morning, the console claimed that one of my tape backup sets had no members, but contained many files. From my experience, waiting for the console further doesn't correct this particular mis-communication, so I quit the console and it was fine after the next launch.
  11. I have experienced this multiple times on 8.2. Usually one script will become more like one of the others and some sources or destinations will be deleted. It is a real problem.
  12. swalker

    8.2 Settings uncertainty

    I did a clean installation of Retrospect redoing the scripts from scratch, adding all the clients, etc. I can now confirm that 8.2 still edits its own settings. When I looked at them this morning two of the scripts were changed. The script which backed up a server is now backing up ordinary PCs instead, and nothing has backed up the server for a week. My proactive backup script now is backing up nothing. So its time to ask again when are the settings going to be separated from the event logging so that my settings will stay put?
  13. From this image it appears that retrospect has a problem reading its own settings. I had never used smart tags anywhere, but they started showing up selected this morning. When I tried to expand the first of the two Tags in the image, the console crashed. On relaunching it, fortunately the Smart Tags selections had disappeared. The problem I have experienced in the past might be a consequence of the settings being read incorrectly, and then, when I edit some other setting, the misinterpreted one also gets saved.
  14. swalker

    8.2 Production worthy?

    I was using a script to restart the engine after it crashed. The beta crashed 26 times between June 25 and August 8th. The next day I installed the release version without changing anything else and it hasn't crashed in the last 10 days. So that problem is at least partly licked. I think the program is still "editing" its own settings though. Will do all the scripts from scratch and see if they are staying put.
  15. swalker

    Finally Gave Up on Retrospect 8

    >I just found that all my tagging is gone, so no backups. I found that most of my sources disappeared from one of my scripts again this week. Similar experience with tagging in the past. Most of 8.2 Retrospect seems solid, but the remaining bugs are annoying. Seems to me there is sloppy programming in a couple of areas that Roxio needs to weed out. When I'm back from vacation, I'll re-install from scratch with fresh preferences if there's another beta out and we'll go from there. 8.2 Engine has crashed 15 times in a month, always weekday mornings. I set up a cron job to log & re-start the engine after a crash which has made the server fairly reliable: #!/bin/sh dat=`date` result=`ps ax | grep "RetroEngine" | grep -v "grep"` if [ "x" == "x$result" ] then /Library/Application\ Support/Retrospect/RetrospectEngine.bundle/Contents/MacOS/RetroEngine & echo "dead $dat" >> /root/retro.log else echo "ok $dat" >> /root/retro.log fi exit
×