Jump to content

alistair

Members
  • Content count

    15
  • Joined

  • Last visited

Community Reputation

0 Neutral

About alistair

  • Rank
    Occasional forum poster
  1. alistair

    Database restores failing

    Here are the extracts from ERRORLOG. The original database is db_cms_01, the renamed attempts are suffixed with _restored ------------ 2009-02-04 14:21:44.10 spid88 Starting up database 'db_cms_01'. 2009-02-04 14:21:44.15 spid88 Bypassing recovery for database 'db_cms_01' because it is marked IN LOAD. 2009-02-04 14:21:52.84 backup Database restored: Database: db_cms_01, creation date(time): 2006/07/07(10:51:33), first LSN: 218:17210:1, last LSN: 218:17212:1, number of dump devices: 1, device information: (FILE=1, TYPE=VIRTUAL_DEVICE: {'dantz_retrospect_vd_db_cms_01'}). 2009-02-04 14:37:16.21 spid58 Starting up database 'db_cms_01_restored'. 2009-02-04 14:37:16.28 spid58 Bypassing recovery for database 'db_cms_01_restored' because it is marked IN LOAD. 2009-02-04 14:37:22.57 backup Database restored: Database: db_cms_01_restored, creation date(time): 2006/07/07(10:51:33), first LSN: 218:17210:1, last LSN: 218:17212:1, number of dump devices: 1, device information: (FILE=1, TYPE=VIRTUAL_DEVICE: {'dantz_retrospect_vd_db_cms_01'}). 2009-02-04 14:55:50.79 spid88 Starting up database 'db_cms_01_restored2'. 2009-02-04 14:55:50.84 spid88 Bypassing recovery for database 'db_cms_01_restored2' because it is marked IN LOAD. 2009-02-04 14:55:57.28 backup Database restored: Database: db_cms_01_restored2, creation date(time): 2006/07/07(10:51:33), first LSN: 218:17210:1, last LSN: 218:17212:1, number of dump devices: 1, device information: (FILE=1, TYPE=VIRTUAL_DEVICE: {'dantz_retrospect_vd_db_cms_01'}). 2009-02-04 15:10:04.93 spid55 Error: 947, Severity: 16, State: 1 2009-02-04 15:10:04.93 spid55 Error while closing database 'db_cms_01_restored' cleanly.. 2009-02-04 15:11:48.70 spid55 Starting up database 'db_cms_01'. 2009-02-04 15:11:50.85 spid55 Recovery is checkpointing database 'db_cms_01' (92) 2009-02-04 15:35:52.90 spid55 Error: 15457, Severity: 0, State: 1 2009-02-04 15:35:52.90 spid55 Configuration option 'show advanced options' changed from 1 to 1. Run the RECONFIGURE statement to install.. 2009-02-04 15:35:52.99 spid55 Using 'xplog70.dll' version '2000.80.760' to execute extended stored procedure 'xp_msver'. 2009-02-04 15:52:59.74 spid55 Process ID 53 killed by hostname MSERVER1, host process ID 5744. 2009-02-04 15:53:40.02 spid55 Starting up database 'db_cms_01'. 2009-02-04 15:55:13.07 spid55 Starting up database 'db_cms_01'. 2009-02-04 15:55:13.12 spid55 Bypassing recovery for database 'db_cms_01' because it is marked IN LOAD. 2009-02-04 15:55:21.23 spid55 Starting up database 'db_cms_01'. 2009-02-04 15:55:21.23 spid55 Bypassing recovery for database 'db_cms_01' because it is marked IN LOAD. 2009-02-04 15:55:23.09 spid55 Recovery is checkpointing database 'db_cms_01' (92) 2009-02-04 15:55:23.49 spid55 Starting up database 'db_cms_01'. 2009-02-04 15:55:26.21 backup Database restored: Database: db_cms_01, creation date(time): 2006/07/07(10:51:33), first LSN: 238:6960:1, last LSN: 238:6963:1, number of dump devices: 1, device information: (FILE=1, TYPE=DISK: {'D:\SQL\MSSQL\BACKUP\db_cms_01_20090204.bak'}). ------------
  2. alistair

    Database restores failing

    Thanks for the quick response. I have tried both. First attempt was to restore the existing database. Then tried letting retrospect create a new database. Same result. When trying a new database the ldf & mdf were created by retrospect. Using SQL Auth with a specially created backup user. This user has all the boxes ticked in the Server Roles tab (ie System Admin, Server Admin etc etc), it doesn't have specific access granted to each db although this should be implied by it's admin roles. Checking them out now, will post once I can get onto the server and find the relevant data.
  3. alistair

    Database restores failing

    Hi, I am getting the following error when trying to restore a database from restore server to remote server. Backup server details SBS2003 SP1 Database server details W2k3 server SP2 MSSQL8 SP3 Servers are connected via Retrospect client over Hamachi VPN. Once the backup fails the database is left non-operational as is reporting as being 'restored' I have tried doing full restore (ie diffs & full) and just diff. Also tried new database and leaving non-operational. Where to from here? Cheers Alistair - 4/02/2009 3:15:53 PM: Restoring from MTT HD3 Restore type: Differential FEncEnd: not started FEncEnd: not started vlocRDiskFileOpen: device number = 0x1 vlocRDiskFileOpen: device number = 0x1 T-7: RestoreStart: id='SYSTEM' T-7: TWDBSqlServer::GetReplacementName:No cluster info, repName = METTROSERVER1 T-7: TWDBSqlDatabase::execSqlRestore: sqlCmd='RESTORE DATABASE [magic3_beesnees] FROM VIRTUAL_DEVICE='dantz_retrospect_vd_magic3_beesnees' WITH REPLACE, NORECOVERY' T-7: execSqlOdbcCommand: id='SYSTEM' T-7: execSqlOdbcCommand: Error on SQLExec. T-7: processSqlMessages: Msg 4,306, SevLevel 16, State 1, SQLState 42000 T-7: (4,306) - The preceding restore operation did not specify WITH NORECOVERY or WITH STANDBY. Restart the restore sequence, specifying WITH NORECOVERY or WITH STANDBY for all but the final step. T-7: processSqlMessages: Msg 3,013, SevLevel 16, State 1, SQLState 42000 T-7: (3,013) - RESTORE DATABASE is terminating abnormally. T-7: MapError: unknown Windows error 4,306 T-7: SQL_Vol::BackupWrite: RestoreWrite failed T-7: ***** BackupWriteClose: total byte restored=5,632 [0x00000000] Trouble writing files, error -1004 (Database Backup/Restore error)
  4. alistair

    Matching takes too long

    I have a similar situation. First I backup one local drive to another local drive then do a transfer backup set to DVD. Currently the DVD backup set has just over 100 disks in the collection. We the transfer back script it takes over an hour to do the 'matching' before any data is actually burnt to disk. Does that sound right? Running latest retrospect on windows2003 sbs/3ghz/4gb ram. Thanks Alistair
  5. Further the post above.. I just did a custom configuration of the DVD drive which executed normally, however am still experiencing the same error. Alistair
  6. I just updated my Small Business Server Premium edition of Retrospect to 7.5.370 and am now getting the following error when trying to write to my DVD burner. Trouble writing media: **Backup Set Name** error -100 (device rejected command) I have tried a few new disks in the drive but get the same error. Prior to the update I had successfully burnt 34 disks in a row. Have even tried a system reboot but no luck there. The DVD in question is a .... Pioneer DVD-RW DVR-107D Version: 1.10 Driver: Pioneer DVD RW (1.56) Should I remove the update & wait for the next version? Cheers Alistair
  7. alistair

    All Databased not being backed up

    Thanks Foster, Is there nobody else at EMC/Dantz that monitors these forums that had knowledge of this specific problem or the SQL Server Agent Addon in general. More than 4 years ago Nate said "I know this is under investigation but I don't have any details beyond that. Please bear with us as we try to track down the cause." Is the issue still under investigation? Surely not. Alistair
  8. alistair

    All Databased not being backed up

    Just updated to v7.5.324 & Hot Fix v7.5.8.101 and retested. Am getting exactly the same issues, I have set the Trees & volumes logging to 6 and can send the log file if that is of any use? Cheers Alistair
  9. Regarding update to 7.5.7.103 that fixes the SBS licensing issue http://forums.dantz.com/ubbthreads/showflat.php/Cat/0/Number/75684 How do I update to that version? I am currently running V7.5.285 (hot fix v7.5.5.103). When choose Retrospect Updates from the Help menu it tells me I can update to 7.5.324. If I install this update will it then let me update further? Or should I wait for my updater to tell me I can go straight to 7.5.7.103? Cheers Alistair
  10. alistair

    All Databased not being backed up

    I see the last post is quite old, has the issue been resolved? I am getting the same problem - a variable number of databases is resolved/backed up. Running v7.5.285, Driver update and Hot Fix, v 7.5.5.103 I realise there is a later version but as a result of a previous error I rolled back to .285 (http://forums.dantz.com/ubbthreads/showflat.php?Cat=0&Board=multiserver&Number=75378&fpart=&PHPSESSID=) Cheers Alistair
  11. Sorry I accidentally deleted your post. It was a mistake! -Forum Admin
  12. I am trying to add a server client add on licence I just purchased to our copy of Retrospect 7.5 Small Business Server Premium. When I enter the license code it comes back with the following error message. Can't add that license code (must first upgrade the Application license) What does it mean 'upgrade the Application license' .. Cheers Alistair
  13. So to use DVD as a backup medium we need to have enough on hand to do a full backup first time. About 46 last count :-) Cheers Alistair
  14. We have about 200GB of data to backup using Retrospect 7.5. What I'd like to do is firstly do a backup to external harddrive then switch to doing nightly normal backups to DVD. From doing a few tests & reading relevent parts of the manual I can't work out a way to do this. Whenever I switch the backup set from the set that contains the hard disk to the set that contains DVD Retrospect starts a compete new backup & asks for enough DVDs to fit 200GB. Am I missing something or is this not possible? Thanks Alistair
  15. How does Retrospect 7.5 handle backing up SQL databases over a VPN link? Does it just compare database to last normal backup & copy down just the data that has changed, or does it copy the whole DB down? We have a copy of RS7.5 for SBS and am wondering if it is worth getting the Server Client Licence Add on and using the SQL licence on the remote machine. Currently we are tossing up using rsync or robocopy to get the backed up databases off that server and on to our local SBS machine & using RS to back up from there. Thanks Alistair
×