Jump to content

pronto

Members
  • Content count

    116
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by pronto

  1. We are using Retrospect since many years on multiple servers and we found out that the bottleneck is the hard drive subsystem in most cases. If Retrospect is running a backup to disk, we never saw a higher performance than round about less than 2 GB/m. This were systems with optimized IO performance (RAID 5 with 12 SAS hard disks on Windows). Linux clients seems to be a bit faster than Windows clients. Now we reached a 3TB limit what is possible to create a full backup to disk and a backup set transfer to tape with Retrospect over a weekend (Friday and Saturday) and we have no hope that we can use Retrospect beyond this size of data. We tried using two GBit LAN interfaces running in a trunk but we couldn't increase the backup performance so I think that the network sub system isn't the bottleneck. HTH Tom
  2. FYI: We tested it with the result that the hard links became dublicated... Bye Tom
  3. Hi community, how does Retrospect 8.x handle with hard links on a Linux client using ext3 as filesystem? We are migrating a huge picture gallery and map the existing gallery with hard links into the new gallery. Does Retrospect generate file duplicates out from this hard links or does it keep the hard link as it is? Thx & Bye Tom
  4. pronto

    Prebackup- Postbackup-Script

    It's on a seperate client machine... Thx & Bye Tom
  5. Hi Community, during a backup an Exchange 2010 server loggs the following events: 204, 403, 401 Does anyone know what causes these errors or how we can prevent it? It should be related to VSS but I don't know how Retrospect deals with VSS Volumes. Thx & Bye Tom 1) 204 ---snip--- Protokollname: Application Quelle: Storage Group Consistency Check Datum: 21.03.2013 23:50:07 Ereignis-ID: 204 Aufgabenkategorie:(3) Ebene: Fehler Schlüsselwörter:Klassisch Benutzer: Nicht zutreffend Computer: UNIVERSE.DOMAIN.local Beschreibung: Instance 2: An attempt to read the database header of '\\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy11\VWL\VWL.edb' failed with error code -1811 (0xfffff8ed). Database header validation failed with this error. Ereignis-XML: <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event"> <System> <Provider Name="Storage Group Consistency Check" /> <EventID Qualifiers="0">204</EventID> <Level>2</Level> <Task>3</Task> <Keywords>0x80000000000000</Keywords> <TimeCreated SystemTime="2013-03-21T22:50:07.000000000Z" /> <EventRecordID>6398</EventRecordID> <Channel>Application</Channel> <Computer>UNIVERSE.DOMAIN.local</Computer> <Security /> </System> <EventData> <Data>2</Data> <Data>\\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy11\VWL\VWL.edb</Data> <Data>-1811 (0xfffff8ed)</Data> </EventData> </Event> ---snap--- 2) 403 ---snip--- Protokollname: Application Quelle: Storage Group Consistency Check Datum: 21.03.2013 23:50:07 Ereignis-ID: 403 Aufgabenkategorie:(6) Ebene: Fehler Schlüsselwörter:Klassisch Benutzer: Nicht zutreffend Computer: UNIVERSE.DOMAIN.local Beschreibung: Instance 2: The physical consistency check successfully validated 0 out of 4294967295 pages of database '\\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy11\VWL\VWL.edb'. Because some database pages were either not validated or failed validation, the consistency check has been considered unsuccessful. Ereignis-XML: <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event"> <System> <Provider Name="Storage Group Consistency Check" /> <EventID Qualifiers="0">403</EventID> <Level>2</Level> <Task>6</Task> <Keywords>0x80000000000000</Keywords> <TimeCreated SystemTime="2013-03-21T22:50:07.000000000Z" /> <EventRecordID>6399</EventRecordID> <Channel>Application</Channel> <Computer>UNIVERSE.DOMAIN.local</Computer> <Security /> </System> <EventData> <Data>2</Data> <Data>0</Data> <Data>4294967295</Data> <Data>\\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy11\VWL\VWL.edb</Data> </EventData> </Event> ---snap--- 3) 401 ---snip--- Protokollname: Application Quelle: Storage Group Consistency Check Datum: 21.03.2013 23:50:07 Ereignis-ID: 401 Aufgabenkategorie:(6) Ebene: Fehler Schlüsselwörter:Klassisch Benutzer: Nicht zutreffend Computer: UNIVERSE.DOMAIN.local Beschreibung: Instance 2: The physical consistency check has completed, but one or more errors were detected. The consistency check has terminated with error code of -106 (0xffffff96). Ereignis-XML: <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event"> <System> <Provider Name="Storage Group Consistency Check" /> <EventID Qualifiers="0">401</EventID> <Level>2</Level> <Task>6</Task> <Keywords>0x80000000000000</Keywords> <TimeCreated SystemTime="2013-03-21T22:50:07.000000000Z" /> <EventRecordID>6400</EventRecordID> <Channel>Application</Channel> <Computer>UNIVERSE.DOMAIN.local</Computer> <Security /> </System> <EventData> <Data>2</Data> <Data>-106 (0xffffff96)</Data> </EventData> </Event> ---snap---
  6. Hi Community, on a Windows 2008 R2 SP2 server we are using a backup client (8.1.0 (266)) connected to a backup server version 8.1 and get on the client machine an error 8194 related to VSS. Does anyone know how we can deal with this error to fix it? Short: There was an unexpected error in IVssWriterCallback -> Access denied. As Microsoft recommend I performed the terminal command 'vssadmin list writers' to determine the writer that causes the problem but no writer errors could be discoverd. Thx & Bye Tom Protokollname: Application Quelle: VSS Datum: 24.03.2013 12:05:28 Ereignis-ID: 8194 Aufgabenkategorie:Keine Ebene: Fehler Schlüsselwörter:Klassisch Benutzer: Nicht zutreffend Computer: UNIVERSE.DOMAIN.local Beschreibung: Volumeschattenkopie-Dienstfehler: Beim Abfragen nach der Schnittstelle "IVssWriterCallback" ist ein unerwarteter Fehler aufgetreten. hr = 0x80070005, Zugriff verweigert . Die Ursache hierfür ist oft eine falsche Sicherheitseinstellung im Schreib- oder Anfrageprozess. Vorgang: Generatordaten werden gesammelt Kontext: Generatorklassen-ID: {e8132975-6f93-4464-a53e-1050253ae220} Generatorname: System Writer Generatorinstanz-ID: {d9f33ab5-d5d7-409e-bc14-87bc67f6247e} Ereignis-XML: <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event"> <System> <Provider Name="VSS" /> <EventID Qualifiers="0">8194</EventID> <Level>2</Level> <Task>0</Task> <Keywords>0x80000000000000</Keywords> <TimeCreated SystemTime="2013-03-24T11:05:28.000000000Z" /> <EventRecordID>7386</EventRecordID> <Channel>Application</Channel> <Computer>UNIVERSE.DOMAIN.local</Computer> <Security /> </System> <EventData> <Data>0x80070005, Access Denied </Data> <Data> Vorgang: Generatordaten werden gesammelt Kontext: Generatorklassen-ID: {e8132975-6f93-4464-a53e-1050253ae220} Generatorname: System Writer Generatorinstanz-ID: {d9f33ab5-d5d7-409e-bc14-87bc67f6247e}</Data> <Binary>2D20436F64653A20575254575254494330303030313236302D2043616C6C3A20575254575254494330303030313231342D205049443A202030303030303531322D205449443A202030303031313138342D20434D443A2020433A5C57696E646F77735C73797374656D33325C737663686F73742E657865202D6B204E6574776F726B53657276696365202020202020202D20557365723A204E616D653A204E542D4155544F524954C4545C4E45545A5745524B4449454E53542C205349443A532D312D352D323020</Binary> </EventData> </Event>
  7. Hi Community, our Backup server (7.7.341 64Bit) crashes during a backup of a Linux client (7.7.100 32 Bit). The client doesn't log any events in /var/log/retroclient.history, the server is logging a system failure a few seconds after starting the backup and closed itself immediately. If we attached the Linux client to the old server (7.7.325 32Bit) the backup finished successfully. Does anybody know what went wrong with this setup or have some workarounds we can test? bye pronto
  8. Okay, here I'm again to complete my soliloquy but maybe someone else could use this information in the future. The VSS related errors 401, 403 and 204 appear when the Exchange database and the transaction logs are stored seperated on different volumes. Since Microsoft recommend under many circumstances differents volumes for the logs and the database I would appreciate a fix for this problem. We are using Version 8.1 for both the server and the agent. Thx & Bye Tom
  9. Hi Community, I'm trying to restore an Exchange 2003 database on a dedicated recovery server in a dedicated recovery domain. I created the new Exchange with the same paths and the same database names, as in the productive server. The recovery starts to restore three files and it works fine as long as the first file become restored but with starting the second file (1.3 GB remaining from round about 200 GB) the restore failed with an error message >>HrESERestoreDatabase 0c7fe1f42 Database not found<<. So now my question is, what the content of the three files is? I thought that one file is the database itself and the two other files contains the transaction logs but now I'm confused. The backup of the productive server contains the database and the public folders of the first storage group, soI count two files but I've no idea what the third file is or why the restore failed starting with the second file. Any hints? Thx & Bye Tom
  10. Hi Community, I didn't found an upgrade instruction from Retrospect Version 7.7 to Version 8.0. Is it possibile to perform an inplace updgrade over the existing installation? And second, is it necessary to update the clients (Windows and Linux) instantly or does it work with the previous version as well for a while? Thx & Bye Tom
  11. Hi Lennart, thanks for your attention and quick reply. But the second question is an "(either) or" question, the yes belongs to which part of the question? Thx & Bye Tom
  12. Hi Community, how does Retrospect deal with ADS (Alternative Data Streams) informations? We are using a third party AFP-server (ExtremeZ-IP) on Windows and this put the Apple EAs (Extended Attributes) directly in the ADS instead of creating the common AppleDouble file. Now it would be interessting how Retrospect take notice about the existing ADS and if we get them back in case of a restore. Normally the EAs on Apple files are unnecessary or caused by cosmetic nature (colored labels on folders for example) but in some cases, like postscript fonts, the data of the file isn't stored in the data fork but in the ressource fork and therefor in an extended attribut and therefor in the ADS on a ExtremeZ-IP based AFP server. Do we running in a problem...? Thx & Bye Tom
  13. Hi Community, all our Windows Server 2008 R2 are logging four error messages in the event list with error ID 8194, Source VSS at this time when the backup starts. I ran the command "vssadmin list writers" without any errors and a Microsoft KnowledgeBase artikel[1] said: "If the command reports that all writers are operating without errors, this means that the error condition is not writer-related. In this case, you should contact the backup software vendor that created the VSS requester application." So here we are and I've no idea what I should do now to get rid of this error messages. [1] http://technet.microsoft.com/en-us/library/cc734235%28WS.10%29.aspx Thx & Bye Tom
  14. Hi, I reinitialized the Backup by trashing the config files but the problem is still the same. I added a new backup client with exact the same version as the problematic client has and this one I can backup without any problems. I asked the customer support for a procedure to manually remove the client. I'm waiting for an answer. I come back after I've the results. Bye Tom
  15. Microsoft and Apple organize user2user forums too and both are frequented by employees also. I think the only reason why this kind of forum is called a user to user forum is because they won't give a guarantee that a technical engineer is working on your problem. But I think some members of the support stuff are still monitoring this forum. I think the user Mayoff for example is a member of the support stuff and he is more than a regular in this forum. He must because nobody can post all day long in this forum ;-) I think thay are reading this but it depends on the style of the criticism if they will take notice about a specific problem.Is the only reason to place a posting here to vent one's anger thay maybe ignore this. I don't know but I would... But you are right this don't eliminate the current problems we have. Bye Tom
  16. Retrospect is an orphan and after EMC absorb Dantz my guess was that the only motivation for this step was to take a rival out of the market because EMC has it's own products. But they keep Retrospect alive unfortunately without any significant progress in development. Maybe Roxio has the motivation to bring Retrospect back to the requirements of the customer. I prefered Retrospect because it is simple and stupid. A backup software shouldn't be to complicated, it should work fail-safe without the need of study a manual with thousands of pages with plenty of parameters which could be configured incorrectly. Retrospect under the command of Dantz met this condition but it become more and more unstable and faulty. Now we reached a point of decision and I hope that Roxio do a better job than EMC did. Bye Tom
  17. I'm in contac with the customer support and tomorrow I will reinstall the server (not really I only trash the config files) and setup a new backup task to this client and if it works (what I don't believe) I build the whole backup new, if not I replace the config files back. After this I install a new Linux client and try it again. If it works I reinstall the server, because it is outdated also in the major realease (currently Debian 4) so an update is anyway necessary. If it doesn't work with a clean installation, I've no idea at this point what I should do but I'm confident that a clean install will work... I will report the results, give me a few days. Bye Tom
  18. pronto

    backup performance

    Okay I will check this out, thanks for this idea. I will report the results as soon as they are available... Bye Tom
  19. Hi Community, I installed the lates version of Retrospect 7.7 on a brand new server with Windows Server 2008 R2 with a brand new SAS attached storage with 12 SATA HDs in a Raid 6, but we have approximately the same speed as we had with the old system. Round about 1000MB/min (+/- 200MB/s). I thought that the network performance is the bottleneck but with using GBit adapters I have round about a load of 25%. The server who become backuped is brand new too and have also the same SAS attached 12 bay storage. Are there some tweaks to increase the performance? Thx & Bye Tom
  20. pronto

    backup performance

    Maybe I missunderstood your intention but do you mean I should break our fileserver backup into more backup sets and run several backup tasks simultaneously? I would never come to this idea but it sounds easy to test and I can imagine that this could tune up the backup bandwidth a bit. Indeed... No we don't run a full backup each day. We run a full backup (or a recycling backup) only on Sunday and from Monday to Friday we run a incremental backup (or a normal backup in Retrospects terminology). On Saturday we copy the complete backup set (including the full backup and all incrementals) on tape which is rotating in a six week cycle except server with databases, they only have a three week cycle because nobody really needs a six week old database. This is only a desaster recovery scenario but the fileserver backup become tested by my Users each week more than one time. Apple+S at the wrong time in the wrong file or corrupted Quark files are prominent examples... Thx & Bye Tom
  21. we are coming from Helios and this was really a very expensive way to establish an AFP server but it works perfectly until Snow Leopard was coming. At this point Helios want a lot of money for an update (for us round about 5.000 Eur, and keep in mind, for an update) but some of the known SL bugs aren't fixed till this day. So we switched to ExtremeZ-IP which comes with a very charming price comparing to Helios. We discussed also the possibility to work with an Apple Server but we decided against it. The major problem is Apples dictatorial hardware branding. If you need a new hardware at the wrong time, unfortunately directly after a new Mac OS release was launched, you have to work with this new OS version and they don't give a damn if there is still a SMB or an AFP bug unfixed or not. We learned this lession with Snow Leopard. Since OSX a new operating was never so critical like Snow Leopard... I will try a restore with some folders who have some EAs respectively some ADS. Bye Tom
  22. pronto

    backup performance

    I can exclude the involved hardware (like switches, Raid subsystems, connectivity etc) as the responsible components, because I transfered an ISO image with round about 3GB in size and indeed I never saw a faster transfer between two computers before. Sensed less than a minute and by using SMB as transport protocol which isn't the fastest. Both servers are brand new with big SAS attached storages with plenty hard drives. Okay the Raid Level (6) isn't known as the fastest but modern controllers can easily deal with high bandwith transmissions. But it is really disappointing that the new backup system isn't faster than the old one. We are in a graphical industrie and have to deal with a large amount of data. We consolidate a few file server to avoid parallel running backups but we only defang the current situation. We will run into the same problem pretty soon. If we do not find a way to increase the backup bandwith significantly, we have only two options. Either we setup a second backup server, and if the backup client is the bottleneck, of course a second file server too, or we test another product. It depend on what is cheaper. For now we are safe to perform a full backup in a useable time slot but now we deal online only with almost 2 TB on data but we expect 4 TB in 12 month. 2 TB are okay but 4 TB isn't possible with this bandwith. And I don't think that our plan to scale our coreswitch up to 10 GBit support will help us in the backup question because now we use only round about 30 % of a GBit connection. The things look bleak for our backup... Bye Tom
  23. pronto

    backup performance

    For testing purposes we turned verification totaly off. The CPU of the server is indeed a MultiCore CPU but at this time nothing else is available, isn't it? The processor load during a backup run is moderate at 60 to 70%. If we performe verification we get higher results up to 2000 MB/min but of course this is explainable because the transmission rate is accumulated with the native backup rate and the verfification rate. And of course the verification rate is much higher than the native backup rate. Do you have a native backup rate around 2 to 3 GB/min? You can see the single values in the logfile... Thx & Bye Tom
  24. pronto

    cannot find clients

    At this time it's not recommended to install a Windows Server 2008 without R2. This is based on a fact but you can go to bed with anyone you want... Bye Tom
  25. pronto

    cannot find clients

    Sounds like a broken Firewall setup on the 2008 Server. Is this a R2 version or only 2008? In my opinion 2008 is only recommended in version R2 which is based on the Windows 7 kernel. 2008 is based on the Vista kernel which is a faulty design. Anyway, both versions of Windows Server 2008 have an outbound firewall too, instead like Windows XP who have only an inbound firewall. If this setup is configured incorrectly, this could cause your problem. Disable for testing purposes the Windows firewalls on both machines (Server and client) completly and try it again... HTH Tom
×