Jump to content

Leaderboard


Popular Content

Showing most liked content since 03/24/2018 in all areas

  1. 1 point
    Sure, I am the Backup, I don't see why not. The only possible glitch I can see is that what you can now purchase is Retrospect Mac 15; Retrospect Mac 14 is obsolete. The cumulative Release Notes for Retrospect Mac 15.0 say "New: Support for LTO-8 tape devices", so the chances are the support for LTO4 devices is still there. In case it isn't, I imagine you can go through Retrospect Sales to get a license code for Retrospect Mac 14.6, which can still be downloaded. The one thing I would caution you about is that the Desktop Edition only supports a single non-autoloader tape drive. If your LTO4 tape drive is fancy-shmancy, you may have to purchase the Single Workstation 20 Client Edition—which is substantially more expensive. You can probably negotiate this with Retrospect Sales, with whom I have no connection other than as a customer.
  2. 1 point
    Andrew Kinnear, I haven't done this myself, just read the User's Guides and half-experimented using my own Retrospect Mac 14.6 "backup server". However, for a media set named "Media Set Example", I think the answers are: [1] It should be fine to use CCC, provided you copy the parent "Retrospect" folder and the "Media Set Example" folder within it as well as the "1-Media Set Example" data file within the "Media Set Example" folder. After you've done the cloning, click the Media Sets category on the left-hand side of the Console, click "Media Set Example" in the list pane, and click the Members button above the detail pane below the list pane. You can then click the the only line in the detail pane (you said you have only one member for each media set), which should be "1-Media Set Example", and after that click the pencil icon at the bottom left of the detail pane; doing so should allow you to redefine the location of "1-Media Set Example"' as being the cloned file instead of the original. After that you shouldn't have to do a Rebuild of "Media Set Example", but if you do the instructions are under the heading "Rebuilding a Media Set"—which is on page 220 of the Retrospect Mac 13 User's Guide (the P.P.P.P.S. of this post explains why I'm looking at that UG instead of the Retrospect Mac 15 UG; the only attempt at an explanation of the functionality I've just described is at the bottom of page 15 of the old version). [2] AFAIK no functionality should be lost for "Media Set ExampleSmall&Cryptic". The reason it shouldn't be is that the snapshot—the basis for most of the functionality—is part of the "Media Set ExampleSmall&Cryptic" Catalog File, which your Copy Media Set script will have created as essentially a duplicate of the "Media Set Example" Catalog File. If there is loss of functionality, IMHO there should be mass developer suicides (insert appropriate smiley here) in Walnut Creek CA, considering that the Copy Media Set type of script was introduced in Retrospect Windows 7.5 by 2008. [3] I don't use software compression or encryption in my humble home installation of Retrospect Mac (I keep last week's rotated USB3 backup disk in my bank safe deposit box), but AFAIK they should be applied if you've specified them when defining "Media Set Example—Small&Cryptic".
  3. 1 point
    haggis999, Here's the link to my post on submitting a Support Case for a bug. If you don't have ASM, which I also don't have, you won't get personalized help in coping with your bug—but at least Retrospect Tech Support will be made aware it exists.
  4. 1 point
    In short an Archive script is a Backup script but with the additional option to delete the copied files from the Source once they have been copied to the Destination and verified.
  5. 1 point
    That would be correct for your setup. My NAS is setup for multiple users with restrictions on which users can access which shares so maintaining the Owner, Group and Permissions on files and folders becomes necessary. I ran a test duplication using Replace Entire Volume with two old Buffalo LinkStation as the destinations and it would appear to be expected behaviour from Retrospect to delete and recopy everything when the destination physically changes. (Duplicate to 'A'; Copy from 'A' to 'B'; Duplicate to 'B') It was having a few of these incidents myself with my camera raw digital images that convinced me to use backup instead of duplicate. If this one has had the same change of destination I suspect it will have the same issues.
  6. 1 point
    It could do with a better name. In use it means the Destination is always an exact copy of the Source. You add a file to the Source it gets added to the Destination. You change a file on the Source it gets updated on the Destination. You delete a file on the Source it gets deleted on the Destination. It will also delete any other files, however they got there, that are on the Destination that are not on the Source. The other options do not delete any deleted or extraneous files. That is what I was hoping you did but this may also be what caused the problem. I don't know about the Synology File Station but the QNAP equivalent has a habit of changing the Owner:Group information on the NAS file system for the copied files. If the Owner:Group on the NAS file system are different to the Owner:Group that Retrospect presents then the files will be seen as different. How were the files duplicated to the backup NAS from the old primary NAS?
  7. 1 point
    Every time a backup is run Retrospect will create a .session file, containing details of the files from that backup, in the same folder as the .rdb files. When Retrospect does a Catalog rebuild it will read these .session files for the necessary information which is faster than reading the individual.rdb files. If you need to perform a thorough rebuild it is necessary to delete the .session files. (During the rebuild the .session files will be recreated.) This feature for faster Catalog rebuilding was added in Retrospect 11 for Windows and Retrospect 13 for Macintosh.
  8. 1 point
    Hopefully your problems are down to a simple typing error. Your folder structure is invalid. It should be \\BONZONAS\PCBackup\Retrospect\Backup Set NAS1(e)\1-Backup Set NAS1(e) (based on your previous posts) not \\BONZONAS\PCBackup\Retrospect\Backup Set NAS1e\1-Backup Set NAS1(e). The member folder name is always the Backup Set folder name with an n- prefix added. You can ignore the following if you like but I'll leave it here for the moment to show how sometimes it easy to overlook what it there in plain sight. I should noticed it in your previous post! I've had a look at the log. Is \\BONZONAS a home-built NAS or a commercial unit such as QNAP or Synology? Retrospect can at least see that there are files in the 1-Backup Set NAS1(e) folder. Retrospect is doing a thorough rebuild of the catalogue by reading the contents of the .rdb files. Had you deleted the .session files from the folder 1-Backup Set NAS1(e) before starting the rebuild? Retrospect is trying to create the AA130340988226970000.session file to a location that does not exist. For some reason that I can't fathom the path for the member folder has been almost duplicated. \\BONZONAS\PCBackup is the NAS and share. \Retrospect\Backup Set NAS1e\1-Backup Set NAS1(e) is as it should be. \Retrospect\Backup Set NAS1(e)\1-Backup Set NAS1(e) is almost duplicated part. ** And this is when I realised it was hopefully a simple typing error **
  9. 1 point
    haggis999, Your question about Forums Search is very apt. In fact the way I found the 2007 post was by searching on "'Backup Set' member location" without the outer quotes, in other words with quotes only around "Backup Set". Indeed I just tried searching on "Cannot use the specified backup data folder" in quotes, and it did not find any posts other than the three in this thread. Strange! As far as -530 errors are concerned, the real point of my paragraph above mentioning them was to suggest—as the linked-to "unconventional approach"—that you consider running Retrospect.exe continuously rather than under control of the Retrospect Launcher. The P.S. in the post I linked to indicates, to the extent I can easily gather evidence using Retrospect Mac 14—which does not have a Launcher, that leaving Retrospect.exe running all the time will likely only cost you on the close order of 250MB real memory when it is not performing any activity. That is IMHO an acceptable cost in these days of cheap multi-gigabyte RAM; my Mac Pro "backup server" has 7GB RAM, the last 4GB of which cost me less than US$50. Doing so would AFAIK enable you to eliminate any permissions problems.
  10. 1 point
    haggis999, I took a look at two out of my three Media Set (Retrospect Mac name for Backup Set) member storage USB drives—the third one is in my bank safe deposit box. Each of them has a "Retrospect" folder on it. Within that folder is a folder with the name of the Media Set—e.g. "Media Set Red"—and also a zero-byte Unix executable named "Backup Media" that was created in August 2015 (when I first started using modern Retrospect with Disk Media Sets) and hasn't been modified since. Within e.g. the "Media Set Red" folder is a file for my single member, named e.g. "1-Media Set Red". (It just so happens that within my "Retrospect" folder on the USB drive named "G-Drive White" I also had, not only the "Media Set White" folder that should be there, but also a "Media Set Red" folder I mistakenly created there in January 2018—which I've just deleted.) The foregoing is the structure required for Retrospect Mac; the structure required for Retrospect Windows may differ. I also did an Advanced Search of the Forums for "'Backup Set' member location". This 2007 post seems to be the best previous answer to your problem; it says you then had to do a Rebuild of the Catalog File, and the post following it told how to avoid the "Cannot use the specified backup data folder" message. There is also this October 2017 post by me—replying to a post by you, suggesting that you create a subvolume on your (presumably old and now dead) NAS.
  11. 1 point
    haggis99, In the "What's New" chapter of the Retrospect Windows 11 User's Guide, page 14 says "Retrospect v11 for Windows and Retrospect v13 for Mac now allow customers to move the member folders of disk sets to new locations and let Retrospect know by simply editing the members and picking the new location. There are scenarios where moving these files is preferable to a set transfer." Presumably this is what you want to do. Unfortunately these sentences were not moved elsewhere in the Retrospect Windows 12 UG, nor were they amplified. Instead they were simply overlaid by the new "What's New" chapter. Being a Retrospect Mac administrator, I don't offhand know how to edit Members in Retrospect Windows. There is an Edit Pencil capability in the Retrospect Mac equivalent of dealing with Backup Sets. I assume that, if you click the Show Members button shown in the dialog on page 410 of the Retrospect Windows 11 UG, you will find something equivalent to that edit pencil that will let you edit the Members and pick their new locations. Retrospect Windows administrators, fee free to chime in with more particulars. BTW you haven't said in this thread what version of Retrospect Windows you are using, but I see from one of your recent posts that you are using Retrospect Windows 12.
  12. 1 point
    Oh, and if it's any consolation, Retrospect for Windows doesn't do this any better (or worse) than the Mac versions. I can't speak to the Linux versions.
  13. 1 point
    The general consensus is that Retrospect is setting permissions (ACLs) on the restored files. Depending on whether they are all "user" files or an OS installation, this may or may not matter but for an OS installation it usually will. The process is incredibly slow. Overnight seems to be not uncommon. The Retrospect user interface for this step leaves a WHOLE LOT to be desired, as there is no status bar, progress report, or active display of file path information to let the user know what is happening (that is, to show that progress is being made), and there's no clear statement of what's being done -- "Completing restore" is remarkably uninformative. Since this has been reported and commented on many times in the past, it's hard to believe that anything will ever be done to make it better. Documentation would help. Dr. Tom Blinn
  14. 1 point
    OK, I've worked this one out. I knew the answer from ages ago but forgot about it. It is one of the idiosyncrasies of Retrospect that it will sometimes open a window off screen. I don't know why, but it happens from time to time and it has done so for many versions, going back for years. It can be easily adjusted by simply clicking WIndow>Arrange All. Simple, but you have to realise what it's done first...irritating little wrinkle.
×